Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing my Bachelor Thesis and am facing some problems with the biblatex package.

I have the following line in my text:

\citet{Lerner.2002} look at this issue [...]

I want this to show like this:

Lerner and Tirole (2002) look at this issue [...]

However, when I use

\usepackage[style=authoryear-icomp,natbib=true,sortcites=true,block=space]{biblatex}

(which I think is the right option?) I get the title:

Lerner and Tirole ("Some simple economics of open source") look at this issue [...]

I am really confused about this, can anybody help? I am using Texmaker and MiKTeX 2.9, if that makes any difference.

EDIT: The .bib entry looks like this:

 @article{Lerner.2002,
 author = {Lerner, Josh and Tirole, Jean},
 year = {2002},
 title = {Some Simple Economics of Open Source},
 pages = {197--234},
 volume = {50},
 number = {2},
 issn = {00221821},
 journal = {The Journal of Industrial Economics}
}
share|improve this question

closed as too localized by egreg, doncherry, percusse, Joseph Wright Jun 22 '12 at 11:33

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What does the .bib entry look like? We can't reproduce your problem without more information… –  Seamus Jun 22 '12 at 9:49
    
I tried to test this, and for me it also used the title, without a year. If I change to natbib it does function. Btw my bibtex is created by mendeley. –  Rick de Groot Jun 22 '12 at 9:54
    
Hello Seamus, the .bib entry looks like this: @article{Lerner.2002, author = {Lerner, Josh and Tirole, Jean}, year = {2002}, title = {Some Simple Economics of Open Source}, pages = {197--234}, volume = {50}, number = {2}, issn = {00221821}, journal = {The Journal of Industrial Economics} } –  padrino Jun 22 '12 at 11:07
    
I solved the problem somehow, but cannot reproduce how exactly unforunately. I tried switching to natbib, didn't find what I wanted there, and when I switched back to BibLatex, somehow it started working like a charm. Thanks for your help! –  padrino Jun 22 '12 at 11:31
    
Glad your problem was solved. It might've been the auxiliary files, which got rewritten when you used natbib. When you're facing strange problems with your bibliography (or table of contents, ...), it's always a good idea to delete your auxiliary files (e.g. via latexmk -c) and compile again. We'll probably close this question as too localized because the problem isn't really reproducible, but don't take offense from that, it's just part of our keeping tidy here. Looking forward to more posts of yours on tex.sx! –  doncherry Jun 22 '12 at 11:33

1 Answer 1

A MWE using all the information you supplied does produce the desired output on my machine, using Texmaker and MiKTeX 2.9.
Is there anything else in your preamble related to bibliographies?

\documentclass{article}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{Lerner.2002, 
    author = {Lerner, Josh and Tirole, Jean}, 
    year = {2002}, 
    title = {Some Simple Economics of Open Source}, 
    pages = {197--234}, 
    volume = {50}, 
    number = {2}, 
    issn = {00221821}, 
    journal = {The Journal of Industrial Economics} 
} 
\end{filecontents}

\usepackage[
    style=authoryear-icomp,
    natbib=true,
    sortcites=true,
    block=space
]{biblatex}
\addbibresource{\jobname.bib} 

\begin{document}
\citet{Lerner.2002} look at this issue [...]
\printbibliography
\end{document}
share|improve this answer
    
Thanks for your reply. I changed to natbib, since Rick de Gout suggested it, and did not get the desired result there. Then I switched back to BibLatex, and somehow it worked. Maybe I just had to rebuild BibTex, though I am sure that I had done that before I asked this question. So it works now, but thank you! –  padrino Jun 22 '12 at 11:27
    
You should not use the natbib and biblatex packages at the same time, they are doing similar things, but they are not compatible. But biblatex has an option natbib and if you set it to true (as in the MWE), you can use the \citet{} and \citep{} commands. –  matth Jun 22 '12 at 11:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.