Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to set the space between paragraphs in beamer (in a block environment).

I tried using \setlength{\parskip}{8pt plus 1pt minus 1pt} in the beginning of the document, with varying numbers (up to 30pt), but that never changed a thing.

Is there a way to set larger spaces between paragraphs when using beamer? I could use \vspace perhaps (did not try), but that sounds like a bad solution.

EDIT: I should have mentioned: I am doing it with beamerposter.sty.

here is a minimal example.

\documentclass[final,t]{beamer}
\mode<presentation>
{
 \usetheme{Warsaw}
}

\usepackage{times}
\usepackage{amsmath,amsthm, amssymb, latexsym}
\usepackage{exscale}
\usepackage{booktabs, array}
\usepackage[english]{babel}
\usepackage[latin1]{inputenc}
\usepackage[orientation=landscape,size=custom,width=230,height=110,scale=1.9]{beamerposter}

\setlength{\parskip}{35pt plus 1pt minus 1pt}

\begin{document}
\begin{frame}{}
\begin{columns}[t]
\begin{column}{.3\linewidth}
  \begin{block}{Title}
  A

  B

  \end{block}
\end{column}
\end{columns}
\end{frame}

\end{document}

A and B should be much more separated, but they are not here.

share|improve this question
    
Changing \parskip works for me, affecting block environments as well. Perhaps post a minimal working example where it doesn't work. –  Stefan Kottwitz Nov 28 '10 at 21:01
    
it seems like I put the parskip setlength command inside the begin{column} command, then the parskip works (though then the header has a blank line in a block which is not needed), but it works only for that block. Isn't there a way to apply it for the whole document as well as avoiding the unnecessary blank line? minimal working example is hard to get because i am using all kind of nonstandard style files... –  beameruser Nov 28 '10 at 21:12
    
Make a copy and reduce step by step - either you'll get a tiny example or isolate the cause to be in one of those steps. For me, \parskip works globally in the preamble. –  Stefan Kottwitz Nov 28 '10 at 21:21
    
This isn't related to your problem, but the times package is obsolete. See the psnfss2e documentation. –  TH. Nov 28 '10 at 22:07
add comment

1 Answer

up vote 4 down vote accepted

By using \addtobeamertemplate you can set \parskip for each block environment:

\addtobeamertemplate{block begin}{}{\setlength{\parskip}{35pt plus 1pt minus 1pt}}

It works with your minimal example.

That command \addtobeamertemplate is very useful for many kinds of modifications.

share|improve this answer
    
This solution almost works for me. It works if I enclose my text inside \begin{block} environment. However, if I put paragraphs directly inside the \begin{frame}, it doesn't work. And yeah, I've tried using {frame begin} in your code, it still doesn't work. –  Denilson Sá Jan 13 '11 at 21:46
    
Oh, well... Just setting \parskip like the sample code in the question works for me. –  Denilson Sá Jan 13 '11 at 21:53
    
@Denilson Sá: fine :-) –  Stefan Kottwitz Jan 13 '11 at 21:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.