Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I try to run pdflatex I get the following error:

Runaway argument?
Latex Error: ./texfile.tex:22 File ended while scanning use of \emph .
Latex Error: ./texfile.tex:24 LaTeX Error: \begin{thebibliography} on input line 1 ended by \end{document}.

Here is my tex-file:

\documentclass[a4paper, abstracton]{scrreprt}
\usepackage[utf8]{inputenc}
\usepackage{booktabs}
\usepackage{graphicx}
\usepackage[final]{pdfpages}
\usepackage{longtable}
\renewcommand{\baselinestretch}{1.5}
\usepackage{setspace}
\usepackage[top=2cm,bottom=3cm,right=2cm]{geometry}
\usepackage{fixltx2e}
\usepackage[square]{natbib}
\usepackage{hyperref}


\begin{document}

\citep{Nawroth:2002zr,Hou:2011vn,Rudini:2008kx,Lampugnani:2006uq,Ishiyama:2010fk,Hudry-Clergeon:2005ys,Angelini:2006vn,Andriopoulou:1999kx,Esser:1998uq,Sun:2012fk,Katsamba:2009kx,Vendome:2011uq,Bennett:1995fk,Ahrens:2003bh,Legrand:2001qf,Harrison:2010ve,Haussinger:2004ly,Parisini:2007zr,Shapiro:1995ys,Patel:2006vn,Boggon:2002kx,Pertz:1999uq,Tamura:1998fk,Cain:2010fk,Taddei:2008ys,Gory-Faure:1999vn,Gulino:1998kx,Gentil-dit-Maurin:2010uq,Corada:2001fk,Breviario:1995vn,Huber:1996uq,Lampugnani:1992fk,Suzuki:1991vn,Larson:2004kx,Breier:1996uq,Potter:2005fk,Tonks:2006fk,Allingham:2007uq,Turowski:2008fk,Vestweber:2012uq,Dejana:2012fk,Harris:2010vn,Huveneers:2012kx,Haidari:2011uq,Nelson:2008fk,Brasch:2011fk,huber:eplin,Abe:2008bh,Kobielak:2004qf,Kametani:2007ve,Drees:2005ly,Pokutta:2000zr,Koslov:1997ys,Rimm:1995vn,Kemler:1989kx,Vestweber:1984uq,Vestweber:1984fk,Lewis:1997fv,Cowin:1986bs,Lampugnani:1995ij,Nelson:2004hc,Orford:1997tg,Aberle:1997kl,Huber:2001oq,Fujita:2002nx,Xiao:2005cr,Huber:2001dq,Huber:1997bh,McCrea:1991ve,McCrea:1991ly,Thoreson:2000zr,Ferber:2002ys,Reynolds:1992vn,Reynolds:1989kx,Reynolds:2004uq,Yonemura:2011fk,Perez-Moreno:2006uq,Pokutta:2007fk,Owen:2008kx,Al-Amoudi:2007uq,He:2003fk,Tsukasaki:2007bh,Leckband:2006qf,Franke:2009ve,Pokutta:2002ly,Tachibana:2000zr,Takai:2008ys,Miyaguchi:2000vn,Hirokawa:1981kx,FARQUHAR:1963uq,Harris:2010fk,Nelson:2008dq,Ogita:2006bh,Ivanov:2001qf,Dejana:2008ve,Yonemura:2010ly,Oda:2011zr,Birukova:2011ys,Giampietro:2012kx,Telo:1998bs,Rampon:2005ij,Bardin:1996hc}


\addcontentsline{toc}{chapter}{Bibliography}
\bibliographystyle{cell}
\bibliography{bib.bib}

\end{document}

And my bib-file is here:

https://gist.github.com/raw/2368d3797ead69cfc6cf/8f75797f1389c1b42c6bfbad71c8ebd01513a40d/bib-file.bib

As far as I understand it a closing bracket is missing in the bib-file, but I cannot find it. The bib-file was generated by BibDesk. Deleting the citation that causes the problem, also doesn't help. The error resurfaces at another citation.

Many thanks in advance!

share|improve this question
1  
Welcome to TeX.sx! I took a look in your .bib file and detected some problems. First, when you run bibtex file, you'll note that the cell style complains about the missing volume field in 5 or 6 entries - which causes an empty \emph{ entry in the generated file.bbl (the error you pointed out). Filling out out the volume field for the entries bibtex complains will solve this particular error. Instead of J{\u}rgen, use J\u rgen (and similar forms) which will solve another issue. :) ctd>> –  Paulo Cereda Jun 25 '12 at 13:41
    
ctd>> And at last but not least, don't use symbols like β directly in your .bib file, since we are using pdflatex (xetex will allow the direct input), it will raise an error when you compile your file. :) –  Paulo Cereda Jun 25 '12 at 13:42
2  
It appears that BibDesk doesn't quite get the creation of characters with diereses (Umlaute). There are seven instances of {\a} that should be {\"a}, and six instances of {\u} that should be {\"u}. There may also be an incorrectly escaped # character in the doi field of the Chretien:1998fk entry. Do make the appropriate global search-and-replace changes in the bib file (or, alternatively check your BibDesk settings and then let BibDesk recreate the bib file from scratch). –  Mico Jun 25 '12 at 14:02
    
@PauloCereda -- fortunately for the OP, the character β only appears to occur in the abstract field of several entries. Unless the OP uses a bibliography style that typesets the abstract field, the presence of this character shouldn't trouble BibTeX. –  Mico Jun 25 '12 at 14:04
    
@Mico: ah yes, you are right. :) I think β only appears in the title of two articles, though there's a bunch of them in the abstract fields. :) –  Paulo Cereda Jun 25 '12 at 14:10
show 4 more comments

1 Answer

By running bibtex, we can find some clues of what is happening:

$ bibtex mydoc
This is BibTeX, Version 0.99d (Web2C 2011)
The top-level auxiliary file: mydoc.aux
The style file: cell.bst
Database file #1: mybib.bib
`volume' is a missing field, not a string, for entry Birukova:2011ys
while executing---line 1461 of file cell.bst
`volume' is a missing field, not a string, for entry Dejana:2012fk
while executing---line 1461 of file cell.bst
`volume' is a missing field, not a string, for entry Giampietro:2012kx
while executing---line 1461 of file cell.bst
`volume' is a missing field, not a string, for entry Sun:2012fk
while executing---line 1461 of file cell.bst
`volume' is a missing field, not a string, for entry Vestweber:2012uq
while executing---line 1461 of file cell.bst
(There were 5 error messages)

The cell style complains about the missing volume field in 5 entries, which causes an unclosed \emph{ entry in the generated myfile.bbl, e.g:

\bibitem[Dejana and Giampietro, 2012]{Dejana:2012fk}
Dejana, E. and Giampietro, C. (2012{\rm{}}).
\newblock Vascular endothelial-cadherin and vascular stability.
\newblock {\rm Curr Opin Hematol } \emph{.

This is the error you pointed out. :)

The standard article data entry has volume as one of the required fields, so we need to declare it, even if we don't have the proper information (it happens sometimes). :)

As Mico pointed out, there are some occurences of words with an Umlaut in your .bib file which require the correct representation, with \"a instead of \a and \"u instead of \u - use J{\"{u}}rgen instead of J{\u}rgen for correct alphabetizing (thanks egreg). And there seems to be an unescaped # symbol in the doi field of the Chretien:1998fk key which will raise an error if not fixed (thanks Mico).

And at last but not least, don't use the β character directly in your .bib file (thankfully, it only appears in the title of two or three entries). Since we are using pdflatex, it will raise an error when you compile your file. Mico also reminds that β appears a lot of times in the abstract fields, but since the cell style does not use this particular field, you are safe for now. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.