Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

in my doc, biblatex-apa seems not to change citation-style to "et al." for a source with three authors after first citing that source, if there are other citations in between.

So, when citing the source the first time it should be "(Stroebe, Nijstad & Rietzschel, 2010)" and the second time "(Stroebe et al., 2010)".

With four authors, it's working as intended in my doc. I compared the entries in the .bib and found nothing wrong. I tried to search for that problem some hours and surprisingly haven't found any entries refering to this problem with up-to-date version of biblatex-apa.

I am totally new to LaTex and just don't know, what else to do.

What am I doing wrong?

I'm using MikTex 2.9, biblatex-apa v1.7 with biber v0.9.9

Here is an example:

\documentclass[a4paper,12pt,oneside,parskip=half]{scrreprt}
\listfiles
\usepackage[american, ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage{csquotes}
\usepackage[backend=biber,style=apa,babel=other]{biblatex}
\DeclareLanguageMapping{german}{german-apa}
\addbibresource{minibib.bib} 
\begin{document}

\parencite{Stroebe2010}.\\
%\parencite{Stroebe2004}?\\ % excluding this, the subsequent citation becomes "et al."
\parencite{Stroebe2010}.

\printbibliography[heading=bibnumbered]
\end{document}

My .bib exported from Mendeley is as follows:

@article{Stroebe2010,
annote = {      },
author = {Stroebe, Wolfgang and Nijstad, Bernard A and Rietzschel, Eric F},
editor = {Psychology, Mark P Zanna and James M Olson B T - Advances in Experimental Social},
isbn = {0065-2601},
journal = {Advances in Experimental Social Psychology},
pages = {157--203},
publisher = {Academic Press},
title = {{Beyond Productivity Loss in Brainstorming Groups: The Evolution of a Question}},
url = {http://www.sciencedirect.com/science/article/pii/S006526011043004X},
volume = {Volume 43},
year = {2010}
}
@article{Stroebe2004,
author = {Stroebe, Wolfgang and Nijstad, Bernard A},
doi = {10.1026/0033-3042.55.1.2},
file = {:C$\backslash$:/Users/Rico/AppData/Local/Mendeley Ltd./Mendeley Desktop/Downloaded/Stroebe, Nijstad - 2004 - Warum Brainstorming in Gruppen Kreativit\"{a}t vermindert.pdf:pdf},
issn = {0033-3042},
journal = {Psychologische Rundschau},
keywords = {1953,brainstorming,creativity,ein einflussreiches buch,ein halbes jahrhundert vor,erscheinen dieses artikels,group processes,group productivity,in dem er ein,osborn,social cognition,verfahren zum,ver\"{o}ffentlichte der werbefachmann alex},
month = jan,
number = {1},
pages = {2--10},
title = {{Warum Brainstorming in Gruppen Kreativit\"{a}t vermindert: Eine kognitive Theorie der Leistungsverluste beim Brainstorming}},
url = {http://psycontent.metapress.com/openurl.asp?genre=article\&id=doi:10.1026/0033-3042.55.1.2},
volume = {55},
year = {2004}
}

Thank you very much for your answers!

share|improve this question
    
Just to be clear for others, the problematic case is the one where et al. isn't used. After first mention, subsequent mentions for >2 authors should use et al. –  Alan Munn Jun 25 '12 at 15:32
    
Thanks! I tried to be more precise now by editing my description. –  Rico Jun 25 '12 at 15:59
add comment

2 Answers 2

up vote 10 down vote accepted

This is, in fact, the correct disambiguation behaviour. When you cite the 2004 paper, the biblatex "uniquelist" feature (which APA requires) expands the name lists to the point of minimum ambiguity which is:

Stroebe & Nijstad et al.
Strobe & Nijstad

However, since "et al" is plural and should not replace only one name, the hidden name is printed instead of "et al". I have confirmed this as correct behaviour with the APA and it will appear in future revisions of the official style.

share|improve this answer
    
Thanks Philip for clarifying this. @Rico you should accept this answer. –  Alan Munn Jun 25 '12 at 17:17
    
Hehe, sure! Thanks a lot!! To all of you 3! Although that means I wasted half a day. Well, APA's a students friend. –  Rico Jun 25 '12 at 19:06
add comment

set maxcitenames

\usepackage[backend=biber,style=apa,babel=other,maxcitenames=3]{biblatex}


enter image description here

share|improve this answer
    
Well, that easy? Thank you very much! I tried maxcitenames=2 before. Seems like I should think about that option again. But anyway, shouldn't do biblatex-apa that automatically since it says so in the examples!? –  Rico Jun 25 '12 at 16:44
    
@AlanMunn: that is obvious that maxcitenames must be set to the maximum of allowed names! –  Herbert Jun 25 '12 at 16:49
    
@Rico: maybe that apa doesn't use maxcitenames because it was not defined in the first versions of biblatex –  Herbert Jun 25 '12 at 16:50
    
@Herbert I removed my comment, because this does work, but there's still an issue with biblatex-apa which is supposed to handle this itself without setting maxcitenames. And the normal behaviour of maxcitenames=3 would have et al. for all citations > 3, but this is not how the APA style works. So it's still a bit of a mystery why this works as it does, since for > 3 but < 6 authors, full names are correctly used. –  Alan Munn Jun 25 '12 at 16:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.