Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm working with TeXnicCenter and I set a up a project file and created my output pdf file and bibliography using biblatex. Everything works well, the document looks the way it should...and now comes the but: I can't get the autocomplete for the \cite{} (any citation command actually) working. I don't even see the references in the reference tab (stable version TeXnicCenter) or in the Literature window (Alpha version). This is a bit annoying, since I have a huge list of references in my .bib file. Does anyone know, how to fix that? Maybe a note, I have just recently switched to biblatex and before I started using it, I could see the references and the autocomplete function was working.

Here is a minimal example of my code:

\documentclass[12pt,a4paper,twoside]{report}  
\usepackage{geometry}  
\usepackage[latin1]{inputenc}    
\usepackage[american]{babel}  
\usepackage{filecontents}    
\usepackage{csquotes}        

\usepackage[style=authoryear-comp,%  
natbib=true,      % enable natbib macros  
bibencoding=ascii,   
url=false,  
sorting=nyt,  
uniquename=false,  
firstinits=true, % use initials as first names  
uniquelist=false,   
dashed=false,     % do not use a dash instead of author name in case of several publications  
maxnames=99,     % in the bibliography show all names   
maxcitenames=2,   % in the text use et al. for more than 2   
backref=true,     % have backrefs in the bibliography   
backend=bibtex8,   
refsegment=section]{biblatex}   

\addbibresource{PhDall.bib}   

\usepackage[T1]{fontenc}   
\usepackage{fancyhdr}   
\usepackage{setspace}   
\usepackage[intoc]{nomencl}  
\usepackage[colorlinks]{hyperref}  
\usepackage[figure,table]{hypcap}  

%-------Main-Document-Body---------  

\begin{document}  

\chapter{test}\label{testchapter}  

lets see if this works: \parencite{albergel_evaluation_2012} and \parencite{maltese_event_2010}  

\printbibliography  

\end{document}   

And the bibliography -which I get from zotero (coding Western - ISO8859-1) -looks like that:

@inproceedings{maltese_event_2010,  
    title = {Event detection of hydrological processes with passive L-band data from {SMOS}},  
    volume = {7824},   
    shorttitle = {Event detection of hydrological processes with passive L-band data from {SMOS}},  
    url = {http://dx.doi.org/10.1117/12.865074},  
    doi = {10.1117/12.865074},  
    booktitle = {{SPIE}},  
    publisher = {{SPIE}},  
    author = {Maltese, Antonio and Al Bitar, Ahmad and Jacquette, Elsa and Kerr, Yann and Mialon, Arnaud and Cabot, Francoise and Quesney, Arnaud and Merlin, Olivier and Richaume, Phillipe},  
    year = {2010},  
    pages = {78240J}  
},

@article{albergel_evaluation_2012,  
title = {Evaluation of remotely sensed and modelled soil moisture products using global ground-based in situ observations},  
    volume = {118},  
    shorttitle = {Evaluation of remotely sensed and modelled soil moisture products using global ground-based in situ observations},  
    url = {http://www.sciencedirect.com/science/article/pii/S0034425711004147},  
doi = {10.1016/j.rse.2011.11.017},  
journal = {Remote Sensing of Environment},  
author = {Albergel, Clement and de Rosnay, Patricia and Gruhier, Claire and {Mu\~{n}oz-Sabater}, Joaquin and Hasenauer, Stefan and Isaksen, Lars and Kerr, Yann and Wagner, Wolfgang},  
year = {2012},  
pages = {215--226}  
}

Any suggestions where I interfer with the autocomplete option?? Thanks

share|improve this question
1  
May be try using \bibliography{example.bib} before \end{document} for autocompletion and comment it before you run the pdflatex –  texenthusiast Jun 26 '12 at 2:38
    
Great! That really does the trick! Amazing...so easy! Thanks a lot :) –  Sandy Jun 26 '12 at 3:53

2 Answers 2

As mention in the comment by texlearner, here the trick:

Try using \bibliography{example.bib} before \end{document} for autocompletion and comment it before you run the pdflatex

share|improve this answer

By adding these three lines

\makeatletter
\@ifpackageloaded{biblatex}{\addbibresource{literatur.bib}}{\bibliography{literatur}}
\makeatother

instead of just

\addbibresource{}

TeXnicCenter believes you are using

\bibliography{}

and integrates it accordingly into the GUI and for autocomplete.

This solution has the beauty of working with both biblatex (+biber) and classic BibTeX and does not need any uncommenting before compiling.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.