Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use the supertabular environment to create a table containing images. I defined that the header should be separated from the content by a single line. Because the first image in table is on the line separating header from content, I have added a space with \\[0.5em] (see MWE). The problem I have is, that the right vertical line of my table now is broken. All other vertical lines are ok. If I remove the space everything is fine, but the image aligns directly to the header line.

How to get the gap on the right vertical line under the table header closed?

Image illustrating problem:

gap on the right vertical line

MWE with gap:

\documentclass[a4paper,12pt,ngerman]{scrreprt}

\usepackage{supertabular}
\usepackage{graphicx}
\usepackage{array}

\begin{document}
\tablefirsthead{\hline\textsc{grafische Notation }& \textsc{Bedeutung} \\\hline \\[0.5em]}
\tablehead{\hline\textsc{grafische Notation }& \textsc{Bedeutung} \\\hline \\[0.5em]}
\tabletail{
\hline
\multicolumn{2}{|r|}{\small Fortsetzung auf nächster Seite}
\\
}
\tablelasttail{\hline}

\begin{supertabular}{|m{0.3\textwidth}|m{0.65\textwidth}|}

\centering  \includegraphics[width=0.25\textwidth]{tex}  &
{ bla}
\\

\centering  \includegraphics[width=0.25\textwidth]{tex}  &
blub\\
\end{supertabular}
\end{document}

MWE without gap:

\documentclass[a4paper,12pt,ngerman]{scrreprt}

\usepackage{supertabular}
\usepackage{graphicx}
\usepackage{array}

\begin{document}
\tablefirsthead{\hline\textsc{grafische Notation }& \textsc{Bedeutung} \\\hline}
\tablehead{\hline\textsc{grafische Notation }& \textsc{Bedeutung} \\\hline}
\tabletail{
\hline
\multicolumn{2}{|r|}{\small Fortsetzung auf nächster Seite}
\\
}
\tablelasttail{\hline}

\begin{supertabular}{|m{0.3\textwidth}|m{0.65\textwidth}|}

\centering  \includegraphics[width=0.25\textwidth]{tex}  &
{ bla}
\\

\centering  \includegraphics[width=0.25\textwidth]{tex}  &
blub\\
\end{supertabular}
\end{document}
share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

you create empty lines after your head settings which is in general not a good idea.

... \\[0.5cm]

this empty tabular line is finished just right after the first column, the reason why the right vertival line isn't drawn. Use:

\tablefirsthead{\hline\textsc{grafische Notation }& \textsc{Bedeutung} \\\hline 
  ~& ~\\[0.5em]}


However, using something like \rule[-1ex]{0pt}{3ex} to get some vertical space in the tabular line makes more sense

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.