Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried to look for a similar problem but could not find any. I hope that anybody with a bit more experience can get me a bit more insight in how I should be using biblatex with XeLaTeX? I think biblatex fully supports UTF-8...

I use the following code (is not a real MWE, since you don't have the bibliographies)

     \documentclass{article}
\usepackage{fontspec,xltxtra}
\usepackage{polyglossia}
    \setmainlanguage{english}
    \usepackage{csquotes}
    \usepackage[bibstyle=numeric, citestyle=numeric-comp, sorting=none]{biblatex}
    \bibliography{cluster}
    \begin{document}
    sometext sometextsometextsom
    test \citep{Wu2004}
    \printbibliography
    \end{document}

I get the following error: Package csquotes Warning: Using preliminary 'polyglossia' interface. (csquotes) Some of the multilingual features may not (csquotes) work as expected.

and as a result of this, my citations keep staying undefined:

Latex warning Citation 'Wu2004' on page 1 undefined on input line 15

Based on the comments I made the following adaptions to my script to utilize biber which is UTF8 aware. However it is not fully working:

\documentclass{article}
\usepackage{fontspec}
\usepackage{xltxtra}
\usepackage{polyglossia}
\setmainlanguage{english}
\usepackage{csquotes}
\usepackage[bibstyle=numeric, citestyle=numeric-comp, sorting=none,backend=biber]{biblatex}%this style compresses the numbering 
\bibliography{cluster}

\begin{document}
sometext sometextsometextsom
test \cite{Wu2004}
\printbibliography
\end{document}

In Texnic center (my editor) I made the following adaptions:

  • changed so it uses biber instead of bibtex: path: C:\additional Tex packages\biber\biber.exe and I passed the following arguments to it: %pm (main file's full path)

the following errors occur, it seems the bbl file is not created.. what am I doing wrong?

Package biblatex Info: Trying to load bibliographic data...
Package biblatex Info: ... file 'testA.bbl' not found.

No file testA.bbl.
Package biblatex Info: Reference section=0 on input line 11.
Package biblatex Info: Reference segment=0 on input line 11.

LaTeX Warning: Citation 'Wu2004' on page 1 undefined on input line 13.


LaTeX Warning: Empty bibliography on input line 14.

[1] (H:\xetex_testing\testA.aux)

LaTeX Warning: There were undefined references.
share|improve this question
    
What's in the cluster bibliography? –  Charles Stewart Nov 29 '10 at 12:54
6  
Biblatex and csquotes support UTF-8, but BibTeX doesn't. For Unicode bibliographies you should use Biber, and you have to inform biblatex about this via the backend option. Also, a warning is not the same as an error. –  Philipp Nov 29 '10 at 13:28
    
thanks for your fast replies people, very much appreciated. I changed my script, taking into account biber.exe that I have installed. But alas it's not working properly yet. –  Timtico Nov 29 '10 at 15:40
    
@Charles Steward the \bibliography{cluster} points to my cluster.bib bibliography file (it's a clustering related manuscript I'm working on) –  Timtico Nov 29 '10 at 15:42
    
Does your biber installation work if you use pdflatex? –  lockstep Nov 29 '10 at 17:01
show 1 more comment

1 Answer

up vote 6 down vote accepted

Thanks for all the assistance people, I was able to come up with a solution, the problem was, that I passed the full tex filename to biber instead of the filename without extension (biber needs the *.bcf file that is created after running latex instead of the *.tex file)

Solution:

First of all make sure you have biber.exe located somewhere on your harddrive. Load the biblatex package with the following preamble \usepackage[backend=biber]{biblatex}

After this set your latex editor to process using biber.exe, in TexnicCenter this works as follows (but examples for other editors such as emacs can be found in the biber.pdf documentation)

From the topmenu: Build/Define Output Profiles/

Path to bibtex executable: <fill in location of biber.exe>

Command line arguments to pass to Bibtex: "%bm" (is same as main file's full path without extension)

Thanks again for all help

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.