Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the documentclass "book". I put a set of \frontmatter and \mainmatter instructions around everything that's before chapter 1. But now, LaTeX skips two pages at the beginning of the main matter. I've tried adding \nopagebreak instructions, even \nopagebreak[4]; it doesn't change anything. LaTeX, still wants pages 1 and 2 to be blank. What am I doing wrong?

EDIT: a \begin{verse} instruction is placed before the first \chapter instruction. Is that wrong?

EDIT: Putting the verse environment after the chapter begins works, but it's not the most "logical" was of describing my content. I guess the question now becomes, "why does putting a verse environment before the chapter declaration cause two blank pages to show up?" Obviously, it has something to do with chapters starting on odd pages, but it's still not very logical.

EDIT: What the wrong code looks like is (simplified, but tested):

\documentclass{book}
\begin{document}
\frontmatter
Lorem Ipsum

\mainmatter
\begin{verse}
% Two blank pages numbered 1 and 2 are inserted here.

\chapter{}
Dolor si amet.

\chapter{}
Lipsum

\end{verse}
\end{document}

Putting the verse environment after the first chapter solves the problem, but the chapters are called from \input commands, so I'd like them to be consistent.

share|improve this question
    
Are you saying that it creates two blank pages with arabic numbers 1 and 2, so that chapter 1 starts on page 3? This shouldn't happen, I think, unless you have added something to the page between \mainmatter and the first \chapter. If this is what happens, can you provide a minimal working example? –  Harald Hanche-Olsen Nov 29 '10 at 14:41
    
I have a custom environment that starts a \begin{verse} environment. Let me try without it. –  eje211 Nov 29 '10 at 15:13
    
Removing the verse environment fixes the issue. How can I keep it without the blank pages? –  eje211 Nov 29 '10 at 15:14
    
Why are you putting a verse environment before your mainmatter? Or is that not what you are doing? You aren't providing enough information for us to get a handle on your problem. –  Harald Hanche-Olsen Nov 29 '10 at 16:29

2 Answers 2

up vote 4 down vote accepted

Your \begin{verse} does put a little (invisible) something in the vertical list, and this is enough for \chapter's call to \cleardoublepage to trigger the output of two empty pages.

Why on earth you would want whole chapters, including chapter titles, to be within a verse environment, is beyond me. My immediate reaction is “don't do that, then”.

If what you want is one humongous poem with chapter titles, I think it is better to just put whole verse environments between the chapter titles.

share|improve this answer
    
Acutally, that deserves an explanation, you're right. I'm not really using the verse environment for verse. I'm using it for a play. I could never get a play set up properly with a word processor or specialised software, and even with my small knowledge of it, LaTeX fills the purpose pretty well. The verse setup, with its negative indent looks good for what I need. I use the chapter separators for acts. There. I don't know (yet) a better way of having the default style for paragraphs look "play-like" without braces. –  eje211 Dec 1 '10 at 0:04
    
Aha! Now we're getting somewhere. The solution, then, would be to teach you how to set up the paragraph style you want without all the side effects of the verse environment – which in its turn is based on the list environment, whose opening \item is causing you all this trouble. I'm a bit busy right now, but I'll get back to you with a bit of advice later, if nobody else beats me to it. –  Harald Hanche-Olsen Dec 1 '10 at 6:50
    
I own and have read most of a copy of "A Guide to LaTeX by Kopka and Daly, but I don't remember anything about defining the DEFAULT paragraph style. Some things I've looked up since were about setting the indent for paragraphs. (I believe that's a Plain TeX thing.) I'll look into that now. –  eje211 Dec 1 '10 at 14:15

You're not providing a minimal example. ;-)

Here's an example using the book class with four pages front matter, four pages main matter and no blank pages in between.

\documentclass{book}

\usepackage{blindtext}

\begin{document}

\frontmatter

\blinddocument

\mainmatter

\blinddocument

\end{document}

EDIT: A \begin{verse} (but no \end{verse}) before your first \chapter command is a) probably wrong b) surely a bad idea and c) surely the cause of your blank pages. What do you want to accomplish using the verse environment?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.