TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I defined the following command:


If I use it like this:


hyperref adds a leading space. Thus the result is "( Req01)" instead of "(Req01)".

How can I disable this leading space?


share|improve this question
up vote 6 down vote accepted

Try the following (note the "%" at the end of the first line):


EDIT: For an explanation see this entry in the UK TeX FAQ.

EDIT2: As your new command takes no argument, the optional count argument [0] in the definition may be omitted.

share|improve this answer
Thanks a lot! It works :-) – Lars Schneider Nov 29 '10 at 17:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.