Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to write a simple letter using the dinbrief class but cannot get it to produce a DIN A4 page. The minimal example is this:

\documentclass[11pt,a4paper]{dinbrief}
\usepackage{german}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{eurosym}
\begin{document}
\subject{Some subject}
\backaddress{Me, some address}
\signature{Me again}
\Datum{Someplace}
\address{my name\\someplace\\some city}
\begin{letter}
{Other guy\\
his city}
\opening{Dear pdfLaTeX,}

why don't you produce the proper page size?

\closing{Kind regards}
\end{letter}
\end{document} 

This produces a US letter sized document when I run pdflatex document from the terminal. I run ubuntu 12.04 with texlive-full packages installed and updated. I would assume the a4paper option in the header is pretty unambiguous...

Am I missing something obvious?

share|improve this question
    
Note that texlive-full is outdated (TeXLive 2009). There is no current version of TL for Ubuntu/Debian at the moment. It is recommended to install TL 2011/12 over its own installer. –  Martin Scharrer Jul 2 '12 at 11:39
    
I know this can happen during dvi2ps conversion, but if you run pdflatex directly that should not happen. –  matth Jul 2 '12 at 11:39
    
@MartinScharrer are there any alternatives to TL that are packaged under Ubuntu? I somewhat dislike the idea of installing a huge set of packages without proper package management. –  black_puppydog Jul 2 '12 at 11:43
    
@black_puppydog: TL comes with its own proper package management (tlmgr) and will be installed in a single directory (/usr/local/texlive usually). There are no binary dependencies between TL and other tools, like editors, so there is no issue here. –  Martin Scharrer Jul 2 '12 at 11:46
    
@black_puppydog try the TL installer provided by TL tug.org/texlive never ever use the ubuntu repos. For package management within TL, TL delivers the so call tlmgr utility. –  bloodworks Jul 2 '12 at 11:49

2 Answers 2

Quite a lot of old classes (e.g. article or your dinbrief) don't set the pdf sizes. An option like a4paper sets only things like the TeX \paperwidth, the linewidth and similar lengths.

You will have to insert the necessary command yourself. For pdflatex this is

\pdfpagewidth=\paperwidth
\pdfpageheight=\paperheight

For latex/dvips you need a \special{...}.

You can also load one of the packages graphicx, or hyperref, or geometry which will set the pdf lengths for you.

Btw: The people who can't reproduce your problem probably have a4paper as default. In this case they would see your problem if they used e.g. the option letterpaper.

share|improve this answer

With Ubuntu 12.10 the default paper size of pdflatex can be changed by running

sudo paperconfig -p a4

This changes some configurations including /etc/papersize, which was set to letter. Beware that there is also a command named paperconf, which does not change anything.

share|improve this answer
    
Welcome to TeX.SX! You may have a look on our starter guide. –  mafp May 14 '13 at 10:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.