Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use the nomencl package. I am following an excellent looking guide available here:


However, I can't for the life of me get even the most basic example working despite the document building with no errors. This is the basic example:

\section*{Main equations}
\nomenclature{$a$}{The number of angels per unit area}%
\nomenclature{$N$}{The number of angels per needle point}%
\nomenclature{$A$}{The area of the needle point}%
The equation $\sigma = m a$%
\nomenclature{$\sigma$}{The total mass of angels per unit area}%
\nomenclature{$m$}{The mass of one angel}
follows easily.

When I build this document (using Texmaker and MikTex 2.9), I get a page with the equations and text. There are no errors or warnings shown and it even creates an ".nlo" file with the correct information inside. But no nomenclature.

Can anyone think of anything I have missed or should try?

share|improve this question
Have you run makeindex <filename>.nlo -s nomencl.ist -o <filename>.nls which the documentation says is necessary? –  clemens Jul 3 '12 at 11:36
You can also automate the makeindex run in TeXnicCenter with these instructions. –  Mike Renfro Jul 3 '12 at 11:57

3 Answers 3

the original code you have posted seems to work also, if you run pdflatex, then makeindex, then pdflatex again. I have copied and pasted your example into a file named n.tex. Then, I did

pdflatex n.tex
makeindex n.nlo -s nomencl.ist -o n.nls
pdflatex n.tex

and it seems to work.

You may also want to check a more up-to-date version of the documentation (the one from CTAN): package page on CTAN; documentation, linked from CTAN

share|improve this answer
@ Jay ... I am working on window 7 not linux, and I am not able to do what you did ... Can you help me please ? –  Muhammad Jul 3 '12 at 12:05
I don't use Windows, but certainly there must be a way to compile the PDF file, then run makeindex, and then compile again. Do you use TeXnicCenter? If you do you could follow Mike Renfro's instructions (see the comment on your post, he mentioned you could check this: tex.stackexchange.com/a/14704/3345) –  Jay Jul 3 '12 at 13:30

In windows you should run the following command in the command prompt:

makeindex <filename>.glo  -s  nomencl.ist  -o <filename>.gls

(I think that .glo and .gls can be .nlo and .nls instead).

To open the command prompt go to Start Menu, type cmd then enter. use cd <path> to go to your working folder and type the command.

To make things easier I'd suggest to keep the nomencl.ist file in the working folder so that the makeindex command can find it.

share|improve this answer
@ Vagelis ... Thanks a lot. But can you tell me where can I find the file nomencl.ist ? –  Muhammad Jul 3 '12 at 12:49
I have solved the problem ... Thanks :) –  Muhammad Jul 3 '12 at 13:39

Go to:

  • Options,
  • Configure TeXmaker,

then in the makeindex box add

%.nlo -s nomencl.ist -o %.els

to the end of whatever is already in the box, separated by a space.

I am using TeXmaker under Windows 8.1 and this worked for me, hopefully its helpful.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.