Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have been using the achicago package and the babel package for spanish language. When I employ the two, references with multiple authors are shown in the citations like (Mukange and Manamela) but it should (Mukange y Manamela) with a "Y", because the thesis is in Spanish. The same happens when the authors are listed in the bibliography.

Is there a way to change the "and" when authors are listed in a citation and in the bibliography for its equivalent in other languages?

share|improve this question
5  
Is biblatex on option for you? It's fully localised and does this sort of thing well. –  PLK Jul 4 '12 at 19:26

2 Answers 2

Some BibTeX styles use \biband, or similar, instead of "and". You can have a look into the .bbl file to see if this is the case, and then renew that command to "y" in the main document.

If, instead, the BibTeX style writes a literal "and" in the .bbl, you are out of luck. In this case I would recommend you to create a customized BibTeX style using custom-bib. To do so, run the command:

$ tex makebst

and then answer a lot of questions about how do you want your bibliography. Give the answers that are consistent with the Chicago style you used to use. When asked about the "and", choose the \biband option. After all questions have been answered, you'll get a .bst file, which is the custom style you should use (\bibliographystyle).

share|improve this answer

Unfortunately, achicago.bst is not fully internationalized, so babel will be of no help here.

You can fix this by hand, however: make a copy of achicago.bst, say myachicago.bst, and place it somewhere where bibtex will find it, e.g., in the directory of your document. Open the new file with an editor, and replace all occurences of " and " with " y " (should be three times, in lines 1318, 1357, 1398). Save the file, and use myachicago as your bibtex style from now on, i.e., with \bibliographystyle{myachicago}.

While you are at it, you might customize other hard coded strings. I spotted "others", ",~eds." (for editors), ",~ed.", "By", "Illustrated by ", "as ", "pp." (for pages), and some more.

share|improve this answer
    
While performing the edits of the renamed .bst file, you may want to recommend changing all instances of "others" to "otros" (or whatever suits the OP's needs). That way, instances of "and others" will be typeset as "y otros"... –  Mico Jan 23 '13 at 0:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.