Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use LyX 2.0 and export with pdflatex.

When writing standard text and exporting to pdf, the font gets rigid. Text written in math mode, though, is exported crystal clear. I've tested that on several computers - but they all show the same problem.

I can't get it, since it's the same font in both cases. Even when choosing italics for standard text, which is how math mode text is showed, I get the same result.

I attached the screenshot below , if for some reason the difference will not show on the pdf itself. (obviously that compromises the quality, but the difference can still be seen clearly).

enter image description here

share|improve this question
3  
It is not the same font. Math and text use different fonts. Screenshots are not very useful, the log-file or the pdf would show the fonts used. But my guess is you should install the cm-super fonts. –  Ulrike Fischer Jul 5 '12 at 22:54

1 Answer 1

up vote 5 down vote accepted

It appears that the problem is that your LyX and LaTeX installation is using bitmap fonts instead of vector fonts for text. Try setting the default roman font for the document to Latin Modern Roman in the document settings.

Document > Settings > Fonts > Roman > Latin Modern Roman

share|improve this answer
1  
Changing the font is probably not very useful since the user is probably missing most of the standard vector fonts from his distribution. Making sure that the vector fonts are actually installed would be the first step. –  ArTourter Jul 5 '12 at 23:00
    
I suppose that is a possibility. However, in LyX's font selection menu fonts that are not installed have a "(not installed)" appended after the name of the font in the menu. As soon as the OP (or whoever) tries to change the font to Latin Modern Roman they will find out whether or not the font is installed. –  JohnReed Jul 5 '12 at 23:04
    
@JohnReed thanks! changed the default roman font as you said and it solved my problem. looks like some kind of magic... –  Mosheke Jul 6 '12 at 8:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.