Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following my question here, there is another one issue that stills unanswered.

Once gain, the following template

http://www-h.eng.cam.ac.uk/help/tpl/textprocessing/ThesisStyle/CUEDThesisPSnPDF.tgz

is supposed to work absolutely fine, however, for some strange reason, it doesn't load the nomenclatures page at all. In fact, I can't even figure out where this information is located within the project.

The only related to this issue information I managed to found is the following lines of LaTeX code:

% Nomenclature
\usepackage{nomencl}
\makenomenclature
\renewcommand\nomgroup[1]{%
  \ifthenelse{\equal{#1}{A}}{%
   \item[\textbf{Roman Symbols}] }{%             A - Roman
    \ifthenelse{\equal{#1}{G}}{%
     \item[\textbf{Greek Symbols}]}{%             G - Greek
      \ifthenelse{\equal{#1}{R}}{%
        \item[\textbf{Superscripts}]}{%              R - Superscripts
          \ifthenelse{\equal{#1}{S}}{%
           \item[\textbf{Subscripts}]}{{%             S - Subscripts
        \ifthenelse{\equal{#1}{X}}{%
         \item[\textbf{Other Symbols}]}{{%    X - Other Symbols
        \ifthenelse{\equal{#1}{Z}}{%
         \item[\textbf{Acronyms}]}%              Z - Acronyms
                        {{}}}}}}}}}}

which are located in the 8th line of file Classes/CUEDthesisPSnPDF.cls

Any suggestion would be highly appreciated!

share|improve this question
    
My guess is that you're not adding the right makeindex command to your build procedure. See this answer or the nomencl documentation, and see if that helps. –  Mike Renfro Jul 7 '12 at 12:16
    
@MikeRenfro: Thank you for your answer. I don't believe that this template has a certain issue, but rather, it is my lack of knowledge on how to use the LaTeX works that causes the problem. Anyway. I am using TeXworks editor. By selecting MakeIndex from the drop-down list and then pressing the green button, I end up with the following message: Couldn't find input index file thesis nor thesis.idx. Usage: makeindex [-ilqrcgLT] [-s sty] [-o ind] [-t log] [-p num] [idx0 idx1 ...] Is that normal? –  eualin Jul 7 '12 at 13:14
    
Anyone who could help me to sort this problem out? –  eualin Jul 7 '12 at 16:09
    
I've read in a German forum that you can add a new procedure for nomencl in TeXworks. It must be somewhere under EDIT > PREFERENCES > TYPESETTING (I haven't worked with TeXworks myself so I can't say more). The forum post shows screenshots which might be helpful. –  cgnieder Jul 7 '12 at 16:17
    
You can't just run makeindex from the TeXworks button. It doesn't pass the right arguments needed to build the nomenclature. You can do any of the following: see section 2.1 of the nomencl documentation and run the makeindex command given there manually, switch editors to something that lets you insert custom commands into the build process (like TeXnicCenter), or use LaTeXmk to build the nomenclature (assuming your version of TeXworks has a LaTeXmk build option. –  Mike Renfro Jul 9 '12 at 0:48

2 Answers 2

You can't just run makeindex from the TeXworks button. It doesn't pass the right arguments needed to build the nomenclature. You can do any of the following: see section 2.1 of the nomencl documentation and run the makeindex command given there manually, switch editors to something that lets you insert custom commands into the build process (like TeXnicCenter), or use LaTeXmk to build the nomenclature (assuming your version of TeXworks has a LaTeXmk build option.

share|improve this answer

I use this thesis template too. To run makeindex I use the following command.

makeindex thesis.nlo -s nomencl.ist -o thesis.nls

I also use TexMaker, and I have set up the following command as a custom quick-build.

pdflatex -interaction=nonstopmode %.tex | bibtex %.aux | makeindex %.nlo -s nomencl.ist -o %.nls | pdflatex -interaction=nonstopmode %.tex | pdflatex -interaction=nonstopmode %.tex | acroread %.pdf &

If running in a terminal, replace % with thesis or whatever your file is called.

Also the template will only create a nomenclature page if you have defined terms in the text.

share|improve this answer
    
Welcome to TeX.sx! –  Andrew Swann Mar 11 '13 at 12:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.