Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like the footnotes from the example to appear comma-separated where they are referenced in the text. The "multiple" option of footmisc should be able to do this, but it does not work. How can I make it work? Am I loading the packages wrongly?

thanks james

MWE:

\documentclass{article}
\usepackage[multiple]{footmisc}
\usepackage{bigfoot}

\DeclareNewFootnote[para]{R}[Roman]
\DeclareNewFootnote[para]{N}

\begin{document}
First sentence.\footnoteR{Here is a footnote.}\footnoteR{Here is another footnote.}\footnoteN{And another one.}\footnoteN{And moe.} And another one.
\end{document}
share|improve this question
1  
I don't think that footmisc can cope with new footnote types defined with bigfoot commands. –  egreg Jul 7 '12 at 19:27
add comment

1 Answer

The fnpct package does handle this correctly:

\documentclass{article}
\usepackage[
  paperwidth=.5\textwidth,
  paperheight=12\baselineskip,
  margin=5pt,
  bottom=1.5cm]{geometry}
\usepackage[dont-mess-around]{fnpct}[2012/07/07] % v0.2d
% the `dont-mess-around' option disables additional kerning
% and punctuation switching.
\usepackage{bigfoot}

\DeclareNewFootnote[para]{R}[Roman]
\DeclareNewFootnote[para]{N}

\begin{document}
First sentence.\footnoteR{Here is a footnote.}\footnoteR{Here is another footnote.}%
\footnoteN{And another one.}\footnoteN{And moe.} And another one.
\end{document}

enter image description here

share|improve this answer
    
Many thanks. I will try to install this package to my Latex installation on OS X and try it out. Would be great if it works! –  james Jul 9 '12 at 10:19
    
@james Did it work? –  cgnieder Jul 12 '12 at 7:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.