Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing my CV and and I am modifying the moderncv package. Since Texlive can update packages and potentially overwrite my changes, I have copied the moderncv package inside my working folder.

However, the moderncv.cls file refers to files that are in the latex distribution folder.

How do I tell the moderncv.cls to find those packages from the default distribution folder?

Environment: MacOS 10.7 + MacTex

share|improve this question

closed as too localized by Joseph Wright Aug 5 '12 at 16:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

9  
Unless moderncv is doing something very curious it should work out of the box. But I would advise you to rename your copy. At least you should change the \ProvidesClass declaration so that you always see in the log-file that you are using a modified class. –  Ulrike Fischer Jul 9 '12 at 15:38
    
Well, actually, I get the error: "The included LaTeX file "size1\@ptsize.clo" was not found" on the copied moderncv. A search from the Terminal points to /usr/local/texlive/2012/texmf-dist/tex/latex/base/. If I copy the base folder into my working folder, problem is solved. However, I want my copied moderncv to link to my tex distribution. –  shailenTJ Jul 9 '12 at 21:21
    
\@ptsize is defined in processing the options 10pt, 11pt and 12pt. i would guess that your revised moderncv.cls doesn't have those options. since i have no access to that file, this can be no more than a guess, i'm afraid. –  wasteofspace Jul 9 '12 at 22:13
    
Run a small document starting with \documentclass{article}. If it finds article.cls in /usr/local/texlive/2012/texmf-dist/tex/latex/base/ then your search pathes are ok and your problem lies elsewhere. (Your error message looks very curious). Make an example that demonstrates your problem and put it together with your modified class and the log-file somewhere for download. –  Ulrike Fischer Jul 10 '12 at 7:35

Browse other questions tagged or ask your own question.