Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using XeLaTeX on OS X 10.6 (texlive installed with MacPorts) I'm not getting any ligatures with Hoefler.

Example code:

\documentclass[10pt]{article}
\usepackage{fontspec,xltxtra}
\setromanfont[Mapping=tex-text]{Hoefler Text}
\begin{document}
ff fl fi ffl ffi
\end{document}

Gives:

enter image description here

From my understanding Hoefler ought to have ligatures, but they're not showing up. Am I missing something?

share|improve this question
1  
What version of TeXLive/XeTeX does MacPorts give you? Your example works fine for me with Mac OS X 10.6 and MacTeX 2010. –  Will Robertson Dec 1 '10 at 7:11
    
The version string shows: This is XeTeX, Version 3.1415926-2.2-0.9995.2 (TeX Live/MacPorts 2009_6) –  Mark Dayel Dec 1 '10 at 16:14
add comment

3 Answers

up vote 9 down vote accepted

It's not that the MacPorts version is broken, it is that by default the MacPorts does not include ATSUI. Rebuild the macports version with sudo port install texlive-bin +atsui should fix the problem. Note that this forces the binaries to be 32-bit (so make sure all dependency has been built in 32-bit or universal) which is why it is not on by default.

share|improve this answer
    
In case it helps anyone: I achieved this by uninstalling all installed ports, and then running sudo port install texlive-bin +atsui +x11; sudo port install texlive +doc +medium; sudo port activate texlive-bin @2012_5+atsui+x11 . That worked for me (and gave me proper ligatures in Zapfino, and let me use alternates as per tex.stackexchange.com/q/33855/15911), but there may well be a quicker way :) –  sampablokuper Mar 18 '13 at 0:08
    
See also: trac.macports.org/ticket/28497 –  sampablokuper Mar 18 '13 at 0:12
add comment

try:

\fontspec[Mapping=tex-text, Ligatures={Common, Rare, Historical}]{Hoefler Text}

Note that "common, rare, historical" will enable a whole bunch of ligatures. if you want the standard ff, ffi, ffl, just the "common" option should suffice.

share|improve this answer
2  
Common is enabled by default; you'll rarely, if ever, have to specify it manually. –  Will Robertson Dec 1 '10 at 7:10
    
Adding the line:\setromanfont[Mapping=tex-text, Ligatures={Common, Rare, Historical}]{Hoefler Text} Doesn't change the output, but gives this error: ` Package fontspec Warning: OpenType feature 'Ligatures=Common' (+liga) not available for font "Hoefler Text/ICU", with script 'Latin', and language 'Default'. This warning occured on input line 6.` (and similar for Rare and Historical) –  Mark Dayel Dec 1 '10 at 16:17
    
P.S. I don't get the 'Ligatures=Common' (+liga) not available error without the Ligatures={Common} option manually enabled. –  Mark Dayel Dec 1 '10 at 16:32
    
are you using the Hoefler Text included with OS X? –  Mica Dec 1 '10 at 17:30
    
Yes---this is the default Hoefler Text that came with the OS (Fontbook identifies it as Hoefler Text; 6.1d7e1; 2009-09-21) –  Mark Dayel Dec 1 '10 at 17:38
add comment

Looks like this is a problem with the macports version of texlive (tried 2009_6 and 2010_0). Installed texlive with MacTeX and ligatures work now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.