Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've been using Lyx (on windows) to write my thesis and for some reason tonight it just stopped working. If i try opening a new file, no layouts are available. I am able to open my thesis file, but I can not compile it (PdfLatex...). Any tips on resolving this would be greatly appreciated.

Update (this was the code that had to be changed as per the link in my comment - the 100 was previously a 65):

\edef\fmtversion{2005/12/01}  
\iftrue  
\def\reserved@a#1/#2/#3\@nil{%  
\count@\year  
\advance\count@-#1\relax  
\multiply\count@ by 12\relax  
\advance\count@\month  
\advance\count@-#2\relax}  
\expandafter\reserved@a\fmtversion\@nil  
\ifnum\count@>100  
share|improve this question

closed as too localized by Stefan Kottwitz Jul 10 '12 at 10:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I won't be able to help you, but I'm sure that those who could will need further details. For example: the version of Win, Lyx and pdflatex that you use; Any sort of error messages which are generated. Finally, did you try simple kill all Lyx related process and restart? –  Dror Jul 10 '12 at 7:51
    
its windows 7 and lyx1.6.7. I was trying to use the tikz package and when I tried to run pdflatex the lyx program 'froze'. I was forced to shut it down (task manager). I then used miktex to install pgfplots. It was after this that I tried opening Lyx and found all my layouts unavailable and that I could not compile my thesis document. I tried restarting my computer several times, as well as Lyx reconfigure. –  Mendy Jul 10 '12 at 7:55
    
update: i tried using texworks to compile a latex file that had worked previously and getting errors with that as well. So the issue must be with my Miktex 2.8. Still at a complete loss on how to resolve it. –  Mendy Jul 10 '12 at 8:27
    
Resolved! Followed the small trick from blog.eddsn.com/2011/06/latex-source-files-more-than-5-years-old and it temporarily fixed the problem. –  Mendy Jul 10 '12 at 8:42
    
@Mendy: Miktex 2.8 has been released 2009. It is quite improbable that its latex has already reached the five-year-limit. Could you please copy all the 10 lines before the \ifnum (starting with \edef\fmtversion)? –  Ulrike Fischer Jul 10 '12 at 12:14

Browse other questions tagged or ask your own question.