TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been reading a very interesting PhD thesis, and I would thus like to reference it in my work.

Unfortunately this bibtex segment didn't work with \cite{}, instead giving [?]:

    title = {The Power of Two Choices in Randomized Load Balancing},
    url = {http://www.eecs.harvard.edu/~michaelm/postscripts/mythesis.pdf},
    school = {Harvard},
    author = {Michael David Mitzenmacher},
    year = {1991}

What am I doing wrong?

share|improve this question

closed as too localized by egreg, Paulo Cereda, percusse, Joseph Wright Jul 12 '12 at 13:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Without a MWE it's impossible to help. – egreg Jul 11 '12 at 12:06
after adding \cite did you run, in order latex bibtex latex latex to re-generate the bibliography? – David Carlisle Jul 11 '12 at 12:11
The entry you posted seems correct. I tested it with a small document and I could cite the entry correctly. So the problem is related to the document, bibliographystyle or other details. – Alexander Jul 11 '12 at 12:11
related: tex.stackexchange.com/questions/49185/… – matth Jul 11 '12 at 13:46
related: tex.stackexchange.com/questions/49185/… – matth Jul 11 '12 at 13:46
up vote 0 down vote accepted

I coded a small test-case to present the commentators with. http://stirkbin.com/a13956

Strangely enough, that test-case worked fine.

So I manually merged all my text into that test-case (which was in another folder)[1], and manually added in my bibtex references (manual = drag+drop from Zotero).

... and it worked.

So I'm not sure why this happened, but the problem is now solved. Feel free to comment if you have ideas on how to prevent this from happening in the future. Thanks.

[1]: Note that before writing questions on tex.stackexchange I always try a clean recompiled after after removing all aux, bbl, blg, log, pdf, bib files.

share|improve this answer
  1. You must have a bibliography style in order to generate a bibliography:

    \bibliographystyle{}  %%sample --> abbrv.bst, abbrvnat.bst etc..
    \bibliography{}       %%sample --> <filename>.bib
  2. Your Citation ID and reference label must be the same:

    \cite{michael_power_1991} - reference citation
    \bibitem{michael_power_1991} - reference label
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.