Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I use \externalfigure after \setupinteraction[state=start], I get an error message about an Undefined control sequence. Here is a minimal working example (filename prob.tex):

\starttext
\setupinteraction[state=start]
\externalfigure[star]
\stoptext

where star.pdf is a small PDF file (and has no known problems). Now when I call ConTeXt on it (Mk iv):

$ context prob
[...]
system          > tex > error on line 4 in file prob.tex: Undefined control sequence ...

1     \starttext
2     \setupinteraction[state=start]
3     \externalfigure[star]
4 >>  \stoptext

By contrast, if I comment out the \setupinteraction command (or set e.g. state=stop), it compiles fine. It also compiles fine if I remove the \externalfigure command, which is what makes me believe that the combination of the two commands is necessary to cause the error.

What am I doing wrong (or is this expected)? I'd like to have interactive links in the PDF, hence the \setupinteraction.

Thanks in advance!

My sincere apologies if this has already been asked. I looked around ([context] setupinteraction externalfigure, using Google, Bing and the Duck thingy) and found nothing.

Details:

$ context --version

mtx-context     | ConTeXt Process Management 0.60
mtx-context     |
mtx-context     | main context file: /opt/context-minimals/texmf-context/tex/context/base/context.mkiv
mtx-context     | current version: 2012.06.26 10:59

$ uname -a
Linux tj-desktop 3.4.4-2-ARCH #1 SMP PREEMPT Sun Jun 24 17:28:37 UTC 2012 i686 GNU/Linux
share|improve this question
1  
I tried compiling your exact example, and it did work for me. I ran it first with MkIV 2012.05.dd (I forget the day); then, because your version was later than mine, I updated with cd /opt/context followed by ./first-setup.sh --keep, and found the MWE also compiles with MkIV 2012.07.10. Perhaps this is a bug specific to the 2012.06.26 version? If you could try updating your ConTeXt, then letting me know (with @Esteis in your comment) whether the problem persists, that would be grand. Also: welcome to the TeX Stack Exchange! –  Esteis Jul 12 '12 at 19:33
    
@Esteis It works! So it was just a version issue, as you supposed. Should have thought of that. Thank you very, very much - this was slowly driving me crazy. –  Thomas Junier Jul 12 '12 at 21:19
    
Congratulations! In that case, I'll just write that in an answer; and if you could accept it, that'll get this question off the 'unanswered' list. We'll keep the question up for now, as it concerns a recent version; but perhaps in a few months we can delete it as 'too localized', as it will apply only to people who will have updated ConTeXt in the week of 2012.06.26, and not since then. –  Esteis Jul 12 '12 at 21:32
    
@Esteis Done. Thanks again! –  Thomas Junier Jul 13 '12 at 6:11

1 Answer 1

up vote 2 down vote accepted

This is a bug with the 2012.06.26 beta. Update ConTeXt with

cd /opt/context
sh ./first-setup.sh --keep

and all will be well.

share|improve this answer
    
Incidentally, in my case there was no first-setup.sh in /opt/context, most probably because I had installed via my distro's installer. The bottom line is: just upgrade, either by hand or using your platform's package manager. –  Thomas Junier Jul 13 '12 at 6:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.