Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was having issues with the regular BibTeX with trying to get it to print a citation style I wanted. Particularly for SAE papers where it is useful to print the SAE Paper number. So I thought I would give BibLaTeX a try as this will allow me to easily make my own style should I need to.

However, as of right now I can't seem to get BibLaTeX (using the biber backend) to even print the citations as they were. Instead of putting a [1] at the cite location its putting the citation key from the bib file with an awkward space at the end like this [Schmidt2011 ]. And the command \printbibliography doesn't do anything at all!.

I get this error on running Biber making me think that there is something up with my bib file which is generated by Mendeley.

INFO - This is Biber 1.0 
INFO - Logfile is 'BiblatexTESTwithUpdatedDPFstuff.blg' 
INFO - Reading 'BiblatexTESTwithUpdatedDPFstuff.bcf' 
INFO - Found 1 citekeys in bib section 0 
INFO - Processing section 0 
INFO - Looking for bibtex format file 'Alex.bib' for section 0
INFO - Decoding LaTeX character macros into UTF-8 INFO - Found BibTeX data source 
'Alex.bib' WARN - Entry Gel does not parse correctly 
WARN - BibTeX subsystem: 
C:\Users\mmam16\AppData\Local\Temp\3y7590B5Os\Alex.bib_7160.utf8, line 4, warning: 95 
characters of junk seen at toplevel 
ERROR - BibTeX subsystem: 
C:\Users\mmam16\AppData\Local\Temp\3y7590B5Os\Alex.bib_7160.utf8, line 1427, syntax error: 
found "and1990", expected "," 
INFO - WARNINGS: 2 INFO - ERRORS: 1

and this is my tex File:

\documentclass[12pt,a4paper,final]{article}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\graphicspath{{./Diagrams/}}
\usepackage[labelfont={sf,bf}, textfont=it, margin=1cm, center]{caption}
\usepackage{subcaption}
\usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
\usepackage[backend=biber,citestyle=numeric-comp,doi=true,url=true]{biblatex}
\addbibresource{Alex.bib}
\begin{document}
Stuff in here \cite{Schmidt2011}.
\begin{figure}[h!]
\centering
\includegraphics[width=0.8\textwidth, keepaspectratio=true]{FilterPoreFunc}
\caption{Cordierite DPF behavior with PM loading. Redrawn and modified from        \cite{Schmidt2011}}
\label{fig:Pores}
\end{figure}
\begin{figure}[h!]
\centering
\includegraphics[width=0.8\textwidth, keepaspectratio=true]{FilterBehave}
\caption{Cordierite DPF behavior with PM loading - Old diagram for comparison. Copied directly from \cite{Schmidt2011}}
\label{fig:Pores2}
\end{figure}
%\bibliographystyle{unsrt}
%\bibliography{Alex}
\printbibliography
\end{document}

What am I doing wrong? The documentation with BibLaTeX is very complete, but it inst half difficult to follow. Any help would be much appreciated (virtual beers all round). Or should I just keep to the older bibtex?

share|improve this question
    
Did you try to delete the .log file and rebuild? But I think mendeley makes bibTeX file and not a biber btw if you remove the backend = biber command it works –  Rick de Groot Jul 13 '12 at 12:25
1  
Make a smaller example (e.g all this \includegraphics have nothing to do with your problem). And show the entry of your bib-file. –  Ulrike Fischer Jul 13 '12 at 12:59
    
According to the contents of the log file, there is (at least) one error in the file Alex.bib: found "and1990", expected ",". Be sure to correct the contents of the bib file appropriately, and then try to rerun latex/biblatex/biber. –  Mico Jul 13 '12 at 13:21
    
We will need to know which versions of biblatex and biber. Are you running: latex, biber, latex? When using biber, you never invoke bibtex (the program) at all. –  PLK Jul 13 '12 at 15:31
add comment

2 Answers 2

Using Mendeley and biblatex here as well and as far as I know Mendeley doesn't produce a Biber file. If I use the backend=biber command I can reproduce your problem, not the error just the citation key instead of the number (this is the biblatex version of the [?] .) If you remove the backend=biber command it should work.

share|improve this answer
    
latest everything MacTex with texlive2012 all up to date. I started a new file from scratch just to test things out and I still get errors. So I remove backend=biber and just run the normal bibtex process? Its still giving me grief. There are no errors this time (Bibtex just notes the style file and the bib file) but running pdflatex, bibtex, pdflatex still leaves citations as the citation key and not a number and I now get a warning about the data encoding being utf8 (which I thought, since texmaker does this bit for you, is perfectly fine to use). –  Alex Mason Jul 16 '12 at 14:40
    
Can you show your .bib file if it's not too large? It seems that there might be errors in there. –  PLK Jul 18 '12 at 18:48
add comment

Search your Mendeley or exportet Bibtex Database for the string and1990. It is most likely, that Mendeley created a citation key that includes a symbol like an apostrophe ' (e.g. O'Hand1990), which is legal for the bibtex backend but illegal for biber backend. So you have two solutions:

  1. Change the citation key in Mendely to a legal string (only letters and numbers). (Recommended option. See also here)

  2. Use bibtex

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.