Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Since I was not happy about the choice of texlive 2009 from Ubuntu repositories, I installed texlive 2012 manually from the website.

Secondly, I like Kile to write, but when I try to install it, it forces me to install all the packages that i want to avoid (2009 version). So I used equivs and made a dummy Ubuntu package that tricks the OS (Ubuntu 12.04 64-bit) into installing kile without those packages.

The problem is that Kile refuses compile.

When I try to do it, from the output I can see that he does:

  • cd into the right directory
  • executes the pdflatex command

And that's it. The funny thing is that repeating the same exact command via the terminal, the file is compiled correctly (I updated correctly the PATH, after all).

Any ideas on how can I get it to work again?

share|improve this question
3  
GUI programs like Kile might only use the PATH variable from config files, not from manual settings. Make sure you put the TL 2012 binary directory in you (exported!) PATH in one of your config files (~/.bashrc maybe?) and then restart or relogin so that the settings take effect. It would also be useful to know how Kile refuses to compile the document, i.e. which error message you are getting. –  Martin Scharrer Jul 14 '12 at 15:38
1  
What does Settings > System Check say? –  Caramdir Jul 14 '12 at 16:19
7  
~/.bashrc is not enough, add it to the front of the PATH setting in /etc/environment instead. Log out and in again. Then the menu started programmes will also be able to find the TL12. –  daleif Jul 14 '12 at 20:14
    
This currently looks like a candidate for being closed for being too localised. But I think there is a really important point here: Kile doesn't work if the PATH is set in .bashrc. Perhaps we could edit things so that the question/answer refer to this specific problem? –  Seamus Jul 15 '12 at 10:37

3 Answers 3

up vote 4 down vote accepted

I had updated the PATH only via .bashrc. With a rapid check of "Settings > Check System" it showed up that Kile did not know where to look for the binaries.

I solved by adding /usr/local/texlive/2012/bin/x86_64-linux to /etc/environment

share|improve this answer
    
After further analysis, for a single user Ubuntu system, adding export PATH=TLPATH:$PATH (path you mention above) to the end of .profile has the same effect and does not require sudo access –  daleif Feb 7 at 13:45

you do not need to install texlive 2012 manually. use the ppa and just update your system: How do I install the latest TeX Live 2012 on Ubuntu 12.04?

share|improve this answer
    
I don't use Ubuntu, so I can not test the howto of the linked page, but it sounds like an easy solution. –  Keks Dose Jul 26 '12 at 12:02

I have sucessfully used the following way:

  1. Remove tex-live-2009 sudo apt-get remove texlive* (kile gets uninstalled too)
  2. Install tex-live-2012 (http://www.tug.org/texlive/acquire-netinstall.html)
  3. Create modified kile deb package without dependency to old tex using the following shell commands (and then install it)
srcpkg=kile_2.1.0-1ubuntu1_amd64.deb 
dstpkg=kile_2.1.0-1ubuntu1_no_texlive_amd64.deb 

apt-get download kile
ar x $srcpkg
tar xzf control.tar.gz

# now remove all the tex-live dependencies
pico control 

tar c post{inst,rm} md5sums control | gzip -c > control.tar.gz
ar rcs $dstpkg debian-binary control.tar.gz data.tar.lzma 

sudo dpkg -i $dstpkg
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.