Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a very strange problem with my list of figures, list of tables and bibliography which I can't figure out. There are unnecessary gaps between the lines. Any idea what could be wrong here?

bibliography enter image description here

The citation looks very regular to me.

@article{Falcone:uq,
Author = {Pete Falcone},
Date-Added = {2012-05-14 21:20:55 +0000},
Date-Modified = {2012-05-14 22:19:24 +0000},
Journal = {The Pantagraph},
Month = {September 28},
Pages = {B1},
Title = {Seattle; Historic Past Makes `Jewel of the Pacific Northwest\' a Precious Commodity},
Year = {1997}}

@book{Florida:2002fu,
Address = {Cambridge, MA},
Author = {Richard Florida},
Date-Added = {2012-05-14 23:18:17 +0000},
Date-Modified = {2012-05-14 23:19:31 +0000},
Publisher = {Basic Books},
Title = {The Rise of the Creative Class},
Year = {2002}}


% \documentclass[a4paper,12pt,twoside,openright,numbers=noenddot]{scrreprt}
\documentclass[a4paper,12pt,numbers=noenddot]{scrreprt}
\addtokomafont{disposition}{\rmfamily}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[british, english, american]{babel}
\usepackage[pdftex]{graphicx}
\usepackage{sidecap}
\usepackage{setspace}
\usepackage{xcolor}
\usepackage{scrpage2} 
\usepackage[hyphens]{url}
\usepackage[format=plain,margin=15pt,parskip=5pt,font=small,indention=10pt]{caption}
\usepackage{makeidx}
\usepackage{hyperref}
\usepackage[final]{pdfpages}
\usepackage[titletoc, title]{appendix}
\usepackage{nomencl}
\renewcommand{\nomname}{List of Abbreviations} 
\makenomenclature
\DeclareCaptionType{map}[Map][List of Maps]
\usepackage{csquotes} 
\usepackage[
  style=mla,
  autocite=footnote
]{biblatex}
\bibliography{Bibliography}
\DeclareCiteCommand{\smartcite}[\iffootnote\mkbibparens\mkbibfootnote]
  {\usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite:mla}}
  {}
  {\usebibmacro{postnote}}
\makeindex
\clubpenalty = 10000 \widowpenalty = 10000 \displaywidowpenalty = 10000
\usepackage{chngcntr}
\counterwithout{figure}{chapter}
\counterwithout{table}{chapter}
\hypersetup{
    colorlinks,%
    citecolor=black,%
    filecolor=black,%
    linkcolor=black,%
    urlcolor=black
}
share|improve this question
4  
Welcome to TeX.SX! I suspect that those high penalties can have a role in the business. But without an example it's difficult to say: it may depend on many other reasons. –  egreg Jul 14 '12 at 21:29
    
As a rule, it's usually a good idea to load the hyperref package last, i.e., after all other packages have been loaded. Well, there a couple of exceptions to this rule, notably for the cleveref package. However, all of the packages you're currently loading after hyperref could be loaded earlier without causing problems. Try loading hyperref last (just before \hypersetup, of course) and see if that makes a difference. –  Mico Jul 14 '12 at 22:32
    
And by example, add some of the seemingly problematic .bib entries: it kind of looks like the two problematic entries are the same 'type' of BibTeX entry. (You can if you want put it all in one file if you use filecontents.) –  jon Jul 15 '12 at 1:15
    
I added the bibtex example, but since it is nothing special, it won't help much. I tried putting hyperref at the end, but that didn't change anything. Also there are other entries of the same type which are perfect. Even if I use setspace for 1.5 or reduced line spacing, the gap remains there. This is really puzzling to me. –  Patrick Jul 15 '12 at 7:36
    
@Patrick May you add the contents of the .bbl file? The two entries corresponding to "Falcone" and "Florida" are needed, exactly as they appear in the .bbl file. –  egreg Jul 15 '12 at 12:39
show 4 more comments

2 Answers

up vote 1 down vote accepted

I've just had no problem with your sample bib entries in an updated version of Biblatex-MLA, which you can find here:

https://github.com/jmclawson/biblatex-mla/tree/dev

Since there have been many fixes between the released version and the updated version, I'm not sure what fixed things, and I'm not sure what caused troubles. Biblatex actually handles everything better than I expected, since your month field in Falcone is formatted oddly. Instead of putting the day there, use the date field to combine the year, month, and date. As an added bonus, setting the entrysubtype field will also format the entry to show up properly as a newspaper article:

@article{Falcone:xx,
    Author = {Pete Falcone},
    Date = {1997-09-28},
    Entrysubtype = {newspaper},
    Journal = {The Pantagraph},
    Pages = {B1},
    Title = {Seattle; Historic Past Makes `Jewel of the Pacific Northwest' a Precious Commodity}}

enter image description here

share|improve this answer
add comment

Ok, I'm closing in on the problem.

The penalties in the bibliography are caused by the MLA option. Once I remove style=mla from biblatex, the gaps in the bibliography are gone.

In the list of figures, the gap exists only between the last figure in a chapter and the first in a new one. This can be hacked:

\begingroup
\renewcommand*{\addvspace}[1]{}
\listoffigures
\endgroup
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.