Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing my thesis and will prefer my table of contents to appear like Table Of Contents centered and not Contents aligned to the left. If U use \tableofcontents it appears to the left.

The other question is how do I take away chapters from my table of content so that it appears like this

                        Table of Contents
Chapter
1 General information
  1.1 data
  1.2 good
2 Background
  2.1 yes
  2.2 hello

in that other can any body come to aid? thanks

share|improve this question
    
Welcome to TeX.StackExchange. You should ask one question at time so it is easier for other with the same problem to find it. –  Spike Jul 15 '12 at 15:40
    
Welcome to TeX.SE! Please provide a bit more information about the setup of your document. E.g., which document class do you use? And, do you load any LaTeX packages that affect the look of the table of contents, i.e., what's produced by the \tableofcontents command? –  Mico Jul 15 '12 at 15:41
    
Please also clarify the intended look of the body of the ToC: Do you want to suppress all page numbers (which would normally be shown at the right-hand end of each row)? –  Mico Jul 15 '12 at 15:49
add comment

1 Answer

I recommend you take a look at the tocloft package. It provides lots of commands to modify the table of contents (and the list of figures, the list of tables, and similar lists).

The following MWE illustrates the usage of the package, using some of the criteria outlined in your posting:

\documentclass{book}
\usepackage{tocloft}
\renewcommand\contentsname{Table of Contents}
\renewcommand{\cfttoctitlefont}{\hfill\large\bfseries}
\renewcommand{\cftaftertoctitle}{\hfill}
\renewcommand\cftchapfont{\mdseries} % default: \bfseries
\cftpagenumbersoff{chapter} % suppress mention of page numbers for chapters, etc
\cftpagenumbersoff{section}
\cftpagenumbersoff{subsection}

\begin{document}
\frontmatter
\tableofcontents
\mainmatter
\addtocontents{toc}{\protect{\mdseries Chapter\par}} % insert the "Chapter" header line
\chapter{General information}
\section{Data}
\section{Good}
\chapter{Background}
\section{Yes}
\section{No}
\end{document}

enter image description here

share|improve this answer
1  
omg, whats with that background color? –  canaaerus Jul 15 '12 at 16:16
    
@canaaerus: I have no idea what's going on: When I view the image in a chrome browser window (or in a safari window on my iPad) the background is plain (i.e., white, transparent), as I intend it to be. However, when I view it in an IE browser window the background is a soft baby-blue... I have no idea what may be causing this oddity. –  Mico Jul 15 '12 at 16:28
    
@mico It's also blue in FF 13 on a Mac. –  Alan Munn Jul 15 '12 at 16:34
    
Strangely in gimp it is white too, but the image properties show under color profile: Lenovo ThinkPad, LCD Monitor, Lenovo ThinkPad LCD Monitor, Copyright (c) 2005 Lenovo Corporation, WhitePoint : D65 (daylight). Maybe some libs are acting on this WhitePoint and adjust the color?!? –  canaaerus Jul 15 '12 at 16:38
    
@canaaerus -- thanks for providing the pointer about the whitepoint profile being embedded. I've changed the save .png settings to exclude any embedding of color profiles. Hopefully this will do the trick. –  Mico Jul 15 '12 at 18:17
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.