Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm searching for a solution of my problem for days:

I use biblax with style apa. There is an option for the case if there are more than one references of ONE author in the same year. Than a letter is inserted after the year. My problem is that there is a letter inserted not only if the references are of the same author but only in the same year regardless of the authors.

My document:

\documentclass[11pt,a4paper,twoside]{report}

\usepackage[ngerman]{babel}                                 %

%\usepackage{fancyhdr}
%\usepackage{hyperref} 
\usepackage{csquotes} 
\usepackage[ style=apa,
            url=false,
            doi=false,
            isbn=false,
            backend=biber,
            hyperref=false,
            eprint=false,
            babel=other
]{biblatex}

\addbibresource{C:/Users/Konsi/Documents/Studium/test.bib}  %ort der bib    %

%\bibliography{C:/Users/Konsi/Documents/Studium/test.bib}   %ort der bib    %
\DeclareLanguageMapping{german}{german-apa}
\DefineBibliographyStrings{german}{andothers={et\ al\adddot}} 



\begin{document}

\parencite{Billard2001}\\
\parencite{Wolpert2001487}

\printbibliography
\end{document}

Than the first problem I have: if I compile this the first time with latex->biber->latex->latex than the .bbl file is not built. Therefor I changed the style to authoryear, latex->biber->latex->latex, .bbl file is built. I changed the style back to apa, everthing is apa conform, except the letters after the years.

My .bib is:

% This file was created with JabRef 2.7.2.
% Encoding: Cp1252


@ARTICLE{Billard2001,
  author = {Billard, Aude},
  title = {Learning motir skills by imitation: A biologically inspired robotiv
    model},
  journal = {Cybernetics and Systems},
  year = {2001},
  volume = {32},
  pages = {155-193},
  number = {1-2},
  doi = {10.1080/019697201300001849},
  eprint = {http://www.tandfonline.com/doi/pdf/10.1080/019697201300001849},
  timestamp = {2012.07.08},
  url = {http://www.tandfonline.com/doi/abs/10.1080/019697201300001849}
}


@ARTICLE{Wolpert2001487,
  author = {Daniel M Wolpert and Zoubin Ghahramani and J.Randall Flanagan},
  title = {Perspectives and problems in motor learning},
  journal = {Trends in Cognitive Sciences},
  year = {2001},
  volume = {5},
  pages = {487 - 494},
  number = {11},
  doi = {10.1016/S1364-6613(00)01773-3},
  issn = {1364-6613},
  keywords = {movement},
  timestamp = {2012.07.07},
  url = {http://www.sciencedirect.com/science/article/pii/S1364661300017733}
}

Could anyone please help me? The second problem is caused by the first maybe, but if so, how can I compile with style=apa?

Thanks a lot!

Edit: Used versions are (I'm not really sure, what is useful and what not): The apa.dbx is missing. is this maybe a problem? I installed the biblatex-apa package with the MiKTeX 2.9 Package Manager.

*File List*
report.cls    2007/10/19 v1.4h Standard LaTeX document class   

size11.clo    2007/10/19 v1.4h Standard LaTeX file (size option) 

babel.sty    2008/07/08 v3.8m The Babel package  

bblopts.cfg    2006/07/31 v1.0 MiKTeX 'babel' configuration 

ngermanb.ldf    2008/07/06 v2.6n new German support from the babel system 

csquotes.sty    2011/10/22 v5.1d context-sensitive quotations 

etoolbox.sty    2011/01/03 v2.1 e-TeX tools for LaTeX

etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)   

keyval.sty    1999/03/16 v1.13 key=value parser (DPC) 

csquotes.def    2011/10/22 v5.1d csquotes generic definitions 

csquotes.cfg     

biblatex.sty    2012/07/01 v2.0 programmable bibliographies (PK/JW/AB) 

biblatex2.sty    2012/07/01 v2.0 programmable bibliographies (biber) (PK/JW/AB)


kvoptions.sty    2010/12/23 v3.10 Keyval support for LaTeX options (HO)  

ltxcmds.sty    2011/04/18 v1.20 LaTeX kernel commands for general use (HO) 

kvsetkeys.sty    2011/04/07 v1.13 Key value parser (HO) 

infwarerr.sty    2010/04/08 v1.3 Providing info/warning/message (HO) 

etexcmds.sty    2011/02/16 v1.5 Prefix for e-TeX command names (HO) 

ifluatex.sty    2010/03/01 v1.3 Provides the ifluatex switch (HO) 

logreq.sty    2010/08/04 v1.0 xml request logger   

logreq.def    2010/08/04 v1.0 logreq spec v1.0   

ifthen.sty    2001/05/26 v1.1c Standard LaTeX ifthen package (DPC)

url.sty    2006/04/12  ver 3.3  Verb mode for urls, etc.   

blx-dm.def

apa.dbx 

biblatex-dm.cfg 

blx-compat.def    2012/07/01 v2.0 biblatex compatibility (PK/JW/AB) 

biblatex.def     

standard.bbx    2012/07/01 v2.0 biblatex bibliography style (PK/JW/AB)

apa.bbx    2012/07/01 v5.0 APA biblatex references style

apa.cbx    2012/07/01 5.0 APA biblatex citation style 

biblatex.cfg       

german.lbx    2012/07/01 v2.0 biblatex localization (PK/JW/AB) 

german-apa.lbx    2012/07/01 v5.0 APA biblatex localisation 

ngerman.lbx    2012/07/01 v2.0 biblatex localization (PK/JW/AB) 
***********
share|improve this question

closed as too localized by Werner, Stefan Kottwitz Jul 16 '12 at 17:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I can't replicate your problem with you MWE. –  Seamus Jul 16 '12 at 9:39
    
Are you sure you have the biblatex-apa file installed? –  Seamus Jul 16 '12 at 9:39
4  
We will need to know which versions you are using. I have just tried your example with biblatex 2.0/biber 1.0 and biblatex-apa 5.0 and it works fine for me. Add a \listfiles to the beginning of your example and check the versions of these packages. –  PLK Jul 16 '12 at 9:40
1  
two more small comments: usually hyperref should be loaded as the last package and maybe you want to change the encoding of your bib file to utf8 (you can also change this setting permanently in JabRef->Options->Settings->Defautl encoding). –  matth Jul 16 '12 at 11:03
    
Ok now it works. I reinstalled biber, biblatex, biblatex-apa and everthing is fine! Thanks for all your help!!! –  user16663 Jul 16 '12 at 16:35
add comment

Browse other questions tagged or ask your own question.