Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am a Ubuntu user, and recently I had a problem with my upgrade from an older version of Ubuntu to a newer one, so I had to wipe everything out and start back from scratch. Unfortunately, that involves setting LaTeX to work back again.

The problem I have is the following : I don't remember what I was using as a LaTeX distribution before, but I know that now I am using TeXLive ; when I run pdflatex, it gives me an error line on every single line in my code, which usually looks like this for one of my average-looking files :

\documentclass[a4paper,10 pt]{article}
\usepackage[isolatin]{inputenc}
\usepackage[T1]{fontenc} 
%\usepackage[francais]{babel}
\usepackage[cyr]{aeguill}
\usepackage{xspace}
\usepackage{fullpage}

%Specific to TikZ

\usepackage{tikz}
\usetikzlibrary{calc}
\usepackage{ifthen}
\usepackage{animate}
....

For instance, I get told from the second line that "File isolatin.def not found" and then my packages ending in ".sty" keep appearing a lot in the errors. If I keep letting them go though (by pressing enter in my terminal, it kind of ignores the warning) I can compile and get my .pdf file, but it won't show with all my pretty packages. Any idea about why this happens? Thank you!

share|improve this question
    
Have you installed the package texlive-full? –  Håkon Malmedal Jul 17 '12 at 17:41
    
Looks like I hadn't... didn't even know about this package! It's installing right now. I'll fill you in with how everything goes afterwards. Thanks to @Higgs for the edit ; that's actually what I wanted to output in my question, but I didn't know how. –  Patrick Da Silva Jul 17 '12 at 18:42
    
@HåkonMalmedal : Thanks! Everything works just fine now. Feel free to type this as an answer and I'll accept it for the upvotes –  Patrick Da Silva Jul 17 '12 at 19:23
add comment

3 Answers

up vote 5 down vote accepted

The package texlive-full is a “metapackage pulling in all components of TeX Live”.

share|improve this answer
add comment

There's never been an isolatin option for inputenc: you probably want latin1.

The package aeguill is very obsolete. To get correct guillemets just load fontenc with the T1 option. You may want also to load the Latin Modern fonts.

\documentclass[a4paper,10 pt]{article}

\usepackage[T1]{fontenc} 
\usepackage[latin1]{inputenc}
%\usepackage[francais]{babel}

\usepackage{lmodern}
\usepackage{xspace}
\usepackage{fullpage}

%Specific to TikZ

\usepackage{tikz}
\usetikzlibrary{calc}
\usepackage{ifthen}
\usepackage{animate}
share|improve this answer
    
I never actually bothered about those packages ; I copy-pasted the list from one of my friends and then just let it there. Thanks for noticing this for me –  Patrick Da Silva Jul 18 '12 at 15:41
add comment

I use the original TeXLive DVD and install it in /opt/texlive/. After installation I set the the path variable to point to the new TeXLive folder. And it works for me. Since I use this method I has no more problem with TeXLive, and I don't use TeXLive distrituted by Ubuntu repos any more.

You can download the DVD here: http: // ctan . org / mirrors (choose one of them), then follow the instruction here: (sorry, I'm a new user so I can post only 2 links pls remove the blank.) (mounting ISO file etc....) http://www.tug.org/texlive/acquire-iso.html

(Install TeXLive) http://www.tug.org/texlive/quickinstall.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.