Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

To include graphics from parent directory I am using

\usepackage{graphicx}
\graphicspath{{../pop/}{../graph/}}

This works fine for MiKTeX but seems to fail for TeX live installed on the same computer (compiler did not find graphics files).

What I'm doing wrong? The directories PoP and Graph are located on the same level as the working directory with the source LaTeX file.

Update: Directory structure (for test purposes I put same graphics files in PoP and Graph subdirecrtories)

ECRH 
|- OS2012
|  |- ECRH(proc).tex
|- PoP
|  |- ECRH-Fig1.pdf
|  |- ECRH-Fig2.pdf
|  |- ...
|- Graph
   |- ECRH-Fig1.pdf
   |- ECRH-Fig2.pdf
   |- ...
share|improve this question
2  
Are the directory names correctly capitalized? –  egreg Jul 18 '12 at 8:07
    
@egreg: I tried \graphicspath{{../PoP/}{../Graph/}{../eps/}} with the same results. –  Igor Kotelnikov Jul 18 '12 at 9:38
    
Can you please add a scheme of what you have? –  egreg Jul 18 '12 at 9:44
    
@egreg: please see update. –  Igor Kotelnikov Jul 18 '12 at 13:12
    
On my system it works (<use ../PoP/pop.pdf> is one of the messages). But it's not Windows. –  egreg Jul 18 '12 at 13:22
add comment

1 Answer

check your security settings in texmf.cnf access to ../ may be turned off. My (default) TL2012 installation allows them for reading:

% Allow TeX \openin, \openout, or \input on filenames starting with `.'
% (e.g., .rhosts) or outside the current tree (e.g., /etc/passwd)?
% a (any)        : any file can be opened.
% r (restricted) : disallow opening "dotfiles".
% p (paranoid)   : as `r' and disallow going to parent directories, and
%                  restrict absolute paths to be under $TEXMFOUTPUT.
openout_any = p
openin_any = a
share|improve this answer
    
It does not work for me. I've checked texmf.cnf, both global and local. –  Igor Kotelnikov Jul 18 '12 at 13:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.