Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

If you try to comment what i have marked you will see the heading picture step one page back respect the title why? Here is the picture. The code is from this post.

\documentclass[%
              twocolumn,            %   COMMENT THIS
              a4paper,%                   % carta A4
              ]{scrbook}

\usepackage{graphicx}                      % immagini

\usepackage{titlesec}

\usepackage{fontspec}

% Bible books (capitoli)
\newcommand{\bbook}[4][]{%
  \makebox[\textwidth][c]{\includegraphics[width=6in]{#4}}
  \chapter[#1]{#2,\\\large #3\\\char"2766}
}
\titleformat{\chapter}[hang]%
   {\centering\huge}%
   {}%
   {0pt}%
   {}
\titlespacing*{\chapter}
  {0pt}{0pt}{5pt}

\setmainfont{EB Garamond 12 Regular}

\begin{document}

\twocolumn[               %   COMMENT THIS

\begin{@twocolumnfalse}   %   COMMENT THIS

\bbook{Title}{title.}{genese_heading}

\end{@twocolumnfalse}     %   COMMENT THIS

]                         %   COMMENT THIS

\end{document}
share|improve this question
    
Not related to the problem probably, but are you sure that pagesize=pdftex and headinclude=on are valid options? The first one doesn't really make sense to me (but I could be wrong) and I can't find it in the Koma-script manual. The second one should be only headinclude or, at least, headinclude=true –  Spike Jul 18 '12 at 20:10
1  
Also it would be a lot easier to debug if you made a Minimal example not using all the fonts and and just using \vspace{3cm} in space of the image. Presumably your positioning issue does not depend on any of them but it is very hard to run your example –  David Carlisle Jul 18 '12 at 20:15
    
Sorry, i have simplified my code... –  FormlessCloud Jul 18 '12 at 20:25
1  
Please fix your broken links. –  Martin Schröder Jul 18 '12 at 22:08

2 Answers 2

Having simplified it so it runs (I see you did that later anyway, thanks) it is simply that \chapter does a clearpage so starts on a new page leaving the image on an earlier page, but when done inside the \twocolumn argument it is happening inside a minipage so page breaking is disabled. If the image is part of a fancy chapter opener it should be part of the definition of \chapter not before it.

\documentclass[%
              twocolumn,            %   COMMENT THIS
              twoside,%
              a4paper,%                   % carta A4
%              paper=a4,
              pagesize=pdftex,
              12pt,
              headinclude=on
              ]{scrbook}


\usepackage{lipsum}

\usepackage{titlesec}


\newenvironment{comment}
  {\par\itshape\scriptsize\hspace{-1em}}
  {\par}

% Bible books (capitoli)
\newcommand{\bbook}[4][]{%
  \makebox[\textwidth][c]{---IMAGE---}%
  \chapter[#1]{#2,\\\large #3\\\char"2766}
}
\titleformat{\chapter}[hang]%
   {\centering\huge}%
   {}%
   {0pt}%
   {}
\titlespacing*{\chapter}
  {0pt}{0pt}{5pt}

% Bible chapters (sezioni)
\newcommand{\bchapter}{%
   \setcounter{verse}{0}%
   \section{}{}
}

\renewcommand{\thesection}{\roman{section}}
\titleformat{\section}[hang]%
   {\booktitlefont\centering}%
   {{capitolo\ \thesection}.}%
   {5pt}%
   {}
\titlespacing*{\section}
  {0pt}{0pt}{0pt}

%*********************************************************************************
% Font
%*********************************************************************************


\begin{document}

%\twocolumn[               %   COMMENT THIS
%\begin{@twocolumnfalse}   %   COMMENT THIS
\bbook{Title}{title.}{genese_heading}
\thispagestyle{empty}
\begin{center}
{ argomento}.
\end{center}
\begin{center}
\parbox{4.65in}{
\begin{comment}
\lipsum[1-1]
\end{comment}
}
\end{center}
%\end{@twocolumnfalse}     %   COMMENT THIS
%]                         %   COMMENT THIS

\lipsum[1-3]

\end{document}
share|improve this answer
    
Thanks ! but i have not understand what i must make for make it work. I have try your code but i have the same problem. –  FormlessCloud Jul 18 '12 at 20:49
1  
well a cheap trick would be to use \cleardoublepage\noindent\begin{minipage}{\textwidth} instead of \twocolumn[ and \end{minipage} instead of ] in the one column case so you get the same effect of page breaking being disallowed. –  David Carlisle Jul 18 '12 at 20:59
    
i have post the final code is it correct? –  FormlessCloud Jul 18 '12 at 22:02
1  
well I removed a blank line so the \noindent applies to the minipage, but that's what I meant yes. Note thi sis easy but suboptimal as it boxes the chapter head, almost certainly the scrbook headings have stretchable glue space to help with page breaking, but putting tings in a box forces the glue to its natural width. As I mentioned in the original answer a full fix would be to modify the chapter heading code and insert the image within that at a suitable point re page and line breaking. –  David Carlisle Jul 18 '12 at 22:24

THANKS DAVID CARLISLE

\cleardoublepage\noindent
\begin{minipage}{\textwidth}

\bbook{Title}{title.}{genese_heading}

\end{minipage}

\vspace{\baselineskip}
share|improve this answer
    
Is it better regarded as an answer or a comment? –  stalking is prohibited Jul 21 '12 at 11:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.