Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use biblatex with verbose and cite via \footcite{...} throughout the document. Problem is: if citing the same source twice, the verbose style outputs author surname and booktitle - but i need it to output author surname and year.

I tried to fix it myself and got so far to change the verbose.cbx in \\MiKTeX 2.9\tex\latex\biblatex\cbx

What I figured out is that (IMHO) is if citeseen is true cite:short or cite:shorthand bibmacro will be used.

And I tried to modify

\newbibmacro*{cite:short}{%
  \printnames{labelname}%
  \setunit*{\nametitledelim}%
  \printtext[bibhyperlink]{%
    \printfield[citetitle]{labeltitle}}}

in this file, using \printfield{year} and whatnot. However there's no effect, even if I delete all these lines. So I might be on the wrong track after all...

If someone knows more and is willing to help - i'd be glad glad glad :)).

Minimal example (or what I consider to be minimal in my case) below:

\documentclass[12p]{scrartcl}
\usepackage[citestyle=verbose, bibstyle=verbose]{biblatex}
\usepackage[ngerman]{babel}
\usepackage[babel,german=quotes]{csquotes}
\bibliography{test}
\renewcommand*{\labelnamepunct}{\addcolon\addspace}
\DeclareFieldFormat
[article,inbook,incollection,inproceedings,patent,thesis,unpublished]
{title}{#1\isdot}
\begin{document}
blala needs a quote \footcite{Schaefers2}\\
quote schaefers2 againt\footcite{Schaefers2}
\printbibliography

\end{document} 

with test.bib containing

@INCOLLECTION{Schaefers2,
author = {Weis, Kurt},
title = {Recht},
editor = {Schäfers, Bernhard},
booktitle = {Grundbegriffe der Soziologie},
publisher = {Leske und Budrich},
adress = {Opladen},
year = {2003},
}
share|improve this question
    
@Audrey yes i noticed this after the (recent?) update to biblatex 2.0 - had problems again for quite a while, but i found what you said on the first pages of the biblatex documentation. biber is now working as well - after reinstall / running all updates there are no version number conflicts anymore... It's likely i'll need some more help soon. However i've learned some things on how to create / modify styles and will first try the possibilities that came to my mind... Guess it will be better to create a new topic for a different problem..? However, thank you very much, so far. –  Martin Jul 24 '12 at 14:33
add comment

1 Answer

First of all, you should not alter the files in the main texmf tree (i.e. in your MiKTeX tree) directly. Instead, you have different options to modify an existing style; lockstep already gave some hints in his answer to this question (in the introduction).

To answer your question: \printdate is the solution you are looking for (see the biblatex documentation for more details). Hence, the following should work:

Edit: As Audrey pointed out, using the labelyear and extrayear fields instead of \printdate avoids ambiguous citations. In order to have these fields available, the option labelyear=true must be loaded. Thus, I enhanced my example:

\documentclass{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usepackage[
  style=verbose,
  labelyear=true,
  backend=biber
]{biblatex}
\addbibresource{biblatex-examples.bib}
\renewcommand*{\labelnamepunct}{\addcolon\addspace}
\DeclareFieldFormat
[article,inbook,incollection,inproceedings,patent,thesis,unpublished]
{title}{#1\isdot}
\renewbibmacro*{cite:short}{%
  \printnames{labelname}%
  \setunit*{\addspace}%
  \printtext[bibhyperlink]{%
    \printfield{labelyear}\printfield{extrayear}}}

\begin{document}
\footcite{companion,knuth:ct:b,knuth:ct:c}

\footcite{companion,knuth:ct:b,knuth:ct:c}
\end{document}

enter image description here

Edit 2: Another possibility is to use the options citestyle=verbose,bibstyle=authoryear instead of labelyear=true. Thereby the extrayear field is also printed in the verbose entries. The appearance of the first citations and the bibliography is then, of course, different, giving the year in parentheses right after the name(s):

enter image description here

share|improve this answer
    
Wow, many many thanks! works like a charm (however i need to omit the option "backend=biber" ..?) many thanks again! :) –  Martin Jul 20 '12 at 0:07
1  
@Martin In biblatex 2.0 the default option setting is now backend=biber. So with this release you'll have to load biblatex with backend=bibtex. BTW: Feel free to accept/upvote domwass's answer as it has solved your question. –  Audrey Jul 20 '12 at 0:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.