Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I use texi2dvi -p --tidy foo.tex where foo.tex contains \bibliography{/home/user/.../mybib.bib}, everything works as expected, mybib.bib is found and references inserted in foo.pdf. Also, when mybib.bib is in the same folder as foo.tex and I use \bibliography{mybib.bib}. However, if mybib.bib is one directory level above foo.tex and I use \bibliography{../mybib.bib}, texi2dvi with the option --tidy (as given above) is not working anymore, it gives:

I couldn't open database file ../mybib.bib
---line 3 of file foo.aux
 : \bibdata{foo-blx,../mybib
 :                           }
I'm skipping whatever remains of this command

How can I specify relative paths in \bibliography so that texi2dvi with option --tidy does not fail?

share|improve this question
add comment

1 Answer 1

Okay, I have it (fairly simple after all). Since the bib(la)tex-related files are in foo.t2d/pdf/build, the relative path in \bibliography should be: ../../../../mybib.bib for mybib.bib to be found.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.