TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have submitted a PDF manuscript to a conference and I get the feedback that my fonts in the verbatim environment either look hideous or they are not rendered at all. The manuscript looks nice on my machine.

I guess this is caused by the Type 3 fonts.

Using Computer Modern Type 1 Fonts with Dvips

And indeed, I get the following warnings when generating the pdf file from the dvi:

dvips: warning: no config file for `amz'
dvips: warning: no config file for `cmz'

I am using Ubuntu 12.04 LTS.

What should I do now? How can I get rid of the Type 3 fonts?

As for a minimal example: since I cannot reproduce this issue on my machine I have no chance to give you a reproducable example.

My attempt would be to put some text into the verbatim environment.

This is the relevant line from the bash script generating the PDF file:

exec dvips -Ppdf -Pamz -Pcmz -j0 -q -f $infile | gs -q -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sOutputFile=$outfile -sPAPERSIZE=a4 $OPTIONS -c save pop

You can see the flags passed to dvips.

share|improve this question
Could you add a minimal example of code and how you're generating your document? – egreg Jul 20 '12 at 9:27
I added some details to the question. I cannot give you an example since I cannot reproduce the problem on my machine. – Ali Jul 20 '12 at 10:05
That's a very old way of doing. The configuration files config.amz and config.cmz have long been removed from TeX Live. exec dvips -f $infile | ps2pdf - $outfile should do. But of course using pdflatex is better. – egreg Jul 20 '12 at 10:18
up vote 5 down vote accepted

If you installed TeX with the Ubuntu package manager you have at least the 2009 version.

Calls such as

dvips -Ppdf -Pamz -Pcmz -j0 -q

are obsolete since quite a long time; the files config.amz and config.cmz have been removed long ago.

You can do the conversion in a much simpler way:

exec dvips -q -f $infile | ps2pdf - $outfile

as dvips and ps2pdf will take care of all the font business.

However, I recommend to compile your document with pdflatex that frees you from all those burdens and directly produces a PDF file, if you don't need PSTricks in your document.

share|improve this answer
Many thanks for the answer! A colleague of mine tried pdflatex (I don't know the details what and how) but the resulting pdf still contained Type 3 fonts. In this case I could use pdflatex but in most cases I am forced to use latex unfortunately. I will try your suggestions and get back to you. – Ali Jul 20 '12 at 10:35
OK, your command generated the right thing: the PDF file contains only Type 1 and 1C fonts. Thanks! :) – Ali Jul 20 '12 at 10:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.