Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I referred multiple sources but nothing is working out. Used TeXShop and it did generated PDF after clicking on "Typeset".

I am missing out something , please help!

share|improve this question
1  
Welcome to TeX.sx! Do you have a TeX distribution installed (e.g. MacTeX)? Did you install the document class moderncv? What exactly isn't working? Do you get any errors? –  doncherry Jul 20 '12 at 12:50
    
I have MacTeX 2011 installed . How to install the document class moderncv ? Also which software to use for installing it ? I have got TexShop , TexWorks , LatexIT installed . –  Gaurang Agrawal Jul 20 '12 at 13:51
    
I don't know, I've never used MacTeX -- I'm a MiKTeX (Win) user. But I'm sure someone knowledgeable about MacTeX will come along soon. –  doncherry Jul 20 '12 at 14:12
    
I you have MacTeX, then moderncv should be installed. –  Peter Breitfeld Jul 20 '12 at 14:23
    
Thanks a lot Doncherry , Peter Breitfeld for kind help . –  Gaurang Agrawal Jul 20 '12 at 15:30
add comment

1 Answer 1

The moderncv package is unfortunately not very well documented. If you have TL 2011 it is installed already and you don't need to install it. The easiest way to get going with it is to try to compile the example template file. To do this, open a terminal window and type:

open -a TeXShop /usr/local/texlive/2011/texmf-dist/doc/latex/moderncv/examples/template.tex

This should open the template file in TeXShop. Before doing anything else, save this file somewhere in your own Documents folder, using the TeXShop File Menu -> Save As... item.

TeXShop's default file encoding is MacRoman, so uncomment line

\usepackage[utf8]{inputenc}

and replace [utf8] with [applemac]. If you have changed TeXShop's preferences to save files in UTF-8 format, then leave the line as it is.

Next comment out the following line:

\photo[64pt][0.4pt]{picture}

(This assumes you have a photo of yourself named picture; since you don't, you should comment this line out.)

Once you've done this, you should be able to typeset the document. If this fails, report back by editing your question.

share|improve this answer
    
Thanks a lot Alan Munn for such an amazing help . –  Gaurang Agrawal Jul 20 '12 at 15:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.