Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Compiling the MWE below:

\documentclass{article}
\usepackage{CountriesOfEurope}
\pagestyle{empty}

\begin{document}
\EUCountry{139}
\end{document}

results in a blank .dvi file, and with both dvips and ps2pdf (or with pdftex), I get error messages telling me that the font CountriesofEurope was not found. I have a complete and updated MikTeX 2.9 installation running on Windows XP and I've checked that the .afm, enc., .map, .pfb, and .tfm files are installed in the corresponding folders. I have updated the FNDB and also ran the shell command updmap.

Any idea on what the problem may be would be welcome.

The .log file from a pdflatex compilation is appended next:

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (MiKTeX 2.9) (preloaded format=pdflatex 2012.7.25)  25 JUL 2012 00:52
entering extended mode
**Europe

("C:\Documents and Settings\_\Mis documentos\LaTeX WinEdt Styles and Files\Euro
pe.tex"
LaTeX2e 
Babel  and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic, 
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2012-05-30, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, latin, latvian,
 lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerman, n
german-x-2012-05-30, nynorsk, oriya, panjabi, pinyin, polish, portuguese, roman
ian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swissgerm
an, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, usengl
ishmax, welsh, loaded.
("C:\Archivos de programa\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
("C:\Archivos de programa\MiKTeX 2.9\tex\latex\base\size10.clo"
File: size10.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
("C:\Archivos de programa\MiKTeX 2.9\tex\latex\CountriesOfEurope\CountriesOfEur
ope.sty"
Package: CountriesOfEurope 2012/04/18 v0.21 CountriesOfEurope Font(RN,hv)
 ("C:\Archivos de programa\MiKTeX 2.9\tex\latex\graphics\keyval.sty"
Package: keyval 1999/03/16 v1.13 key=value parser (DPC)
\KV@toks@=\toks14
))
No file Europe.aux.
LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Font shape `U/CountriesOfEurope/m/n' will be
(Font)              scaled to size 10.0pt on input line 6.
[1

{C:/Documents and Settings/_/Configuración local/Datos de programa/MiKTeX/2.9/
pdftex/config/pdftex.map}]
("C:\Documents and Settings\_\Mis documentos\LaTeX WinEdt Styles and Files\Euro
pe.aux") ) 
Here is how much of TeX's memory you used:
 325 strings out of 493921
 4053 string characters out of 3144430
 49070 words of memory out of 100000000
 3697 multiletter control sequences out of 15000+200000
 3900 words of font info for 15 fonts, out of 3000000 for 9000
 841 hyphenation exceptions out of 8191
 23i,4n,19p,164b,100s stack positions out of 5000i,500n,10000p,200000b,50000s

!pdfTeX error: pdflatex (file CountriesOfEurope): Font CountriesOfEurope at 600
 not found
 ==> Fatal error occurred, no output PDF file produced!
share|improve this question
    
I use the latest update of Miktex 2.9 under Win 7, and dvi, dvi->ps->pdf and PDFLaTex work fine and output the Finland shape. –  Tom Bombadil Jul 23 '12 at 23:17
    
I do get a blank page with pfdlatex/TeXLive2011, so perhaps TeXLive2012 is required? However, if I use XeLaTeX things work fine with TexLive2011. –  Peter Grill Jul 23 '12 at 23:38
    
@Kurt: I updated my MikTex2.9 installation yesterday and the files went to the TDS-compliant MikTeX 2.9 default folder. It must run from there. Maybe we should contact the package authors? –  Marcos Jul 24 '12 at 0:48
    
@Kurt: I have uninstalled and installed again, but I get the same result. –  Marcos Jul 24 '12 at 2:58
    
I just installed the package in miktex 2.9. and your example works fine. So it is not a problem with the package but with your installation. Show the log-file of a pdflatex(!) run and also tell the exact path of the .pfb. –  Ulrike Fischer Jul 24 '12 at 9:25

1 Answer 1

up vote 1 down vote accepted

The CTAN catalog says that MikTeX does include the package CountriesofEurope. My actual installation of MiKTeX 2.9 does not. The package manager of MikTeX tolds me that Package CountriesofEurope is realy not installed.

Please install the package with the manager and your MWE will run. Install the package with Windows-start - all Programs - MiKTeX 2.9 - Maintanance (Admin) - Package Manager (Admin). Then choose CountriesofEurope and click on the green + sign.

share|improve this answer
    
That's what I've done. I've done this from WinEdt 6 and also from the command line (on Windows XP). I've ran texhash --admin and initexmf --admin -u, and the result is the same. Actually, there is some problem with my MikTeX installation, since the packages that have been added starting with my last update (i.e., those non-existant before in my installation) are not found -- the files are there, though. Any idea on something else I can try to effectively refresh the FNDB? –  Marcos Jul 25 '12 at 3:49
    
It is important to know how you have installed your MikTeX. Maybe this helps you? –  Kurt Jul 25 '12 at 13:53
    
It was helpful indeed, but mostly to check that I had already proceeded like described there. As a last resort, I'm going to unistall and install again from scratch. That means some work, but hopefully I'll have it running cleanly again. –  Marcos Jul 25 '12 at 16:31
    
@Marcos Did you succeed? BTW: the current version of MiKTeX shows the package in the package manager ... –  Kurt Aug 25 '13 at 8:13
    
My gosh ;-) This has some age... Yes, as I said in my comments, something seemed to be going on with my installation, because none of the suggestions turned out to be useful and only after a fresh full installation it worked. Now I think that I could have as well checked your answer, since it may lead somebody else with a similar problem to a solution. –  Marcos Aug 25 '13 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.