Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to insert "ç". Tried including \usepackage[utf8]{inputenc}, and type \c {c} , but doesn't work.

share|improve this question
    
    
you don't say how this doesn't work, so i'm guessing. if you redefined \c you would get either an error or surprising output; i'd check for that first. but of course if you have the letter on your keyboard, it's easiest to use that if you're using inputenc with an appropriate option. –  barbara beeton Jul 27 '12 at 12:28
add comment

3 Answers 3

up vote 13 down vote accepted

If you load inputenc with the utf8 encoding option (make sure that your editor is also configured to use Unicode), you can input those characters directly from your keyboard:

\documentclass{article}
\usepackage[utf8]{inputenc}

\begin{document}
Ç et ç
\end{document}

enter image description here

A few comments (added by herve):

If your keyboard has not a french layout, the way to input it are (on a mac using international keyboard: alt+c , on a linux box compose followed by coma followed by c.

\c c should work without use of \usepackage[utf8]{inputenc}.

share|improve this answer
    
Thanks, problem solved. I have some conflicts between packages(I guess.) I further added \usepackage[T1]{fontenc} and it finally works. I don't know why though. I typed ç directly in the text. –  user16739 Jul 27 '12 at 3:15
1  
Adding \usepackage[T1]{fontenc} to your preamble is a good thing, but sadly it will load a bitmap font by default. To fix this, you should install the cm-super package or load a vector font. –  matth Jul 27 '12 at 8:57
    
You are right. The whole text is changed. I don't know what to do now. –  user16739 Jul 27 '12 at 15:22
    
@user16739 It's hard to tell without seeing your actual settings. Perhaps you should open a fresh new question showing a minimal and complete version of your document illustrating the problem. Since the issue of the original question was solved, I don't see why you un-accepted the answer. You can always start follow-up questions for new issues. –  Gonzalo Medina Jul 27 '12 at 15:29
    
It's not solved.\usepackage[french]{babel} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc}--those three package couldhelp insert ç, but they also change the other English characters. If I omit one package, error occurs. –  user16739 Jul 27 '12 at 15:33
show 3 more comments

Simply \c{c}, no space.

I believe you are trying a space between \c and {c}.

share|improve this answer
    
Welcome to TeX.sx! Feel free to visit our TeX.SX starter guide to get the most of our site. –  Peter Jansson May 16 '13 at 7:30
1  
This can't be the problem: space after command sequences is automatically gobbled. \c c, \c {c}, and \c{c} are treated the same (provided '`', 'c`', '{', '}', and '` `' have the usual catcodes). –  Charles Stewart May 16 '13 at 8:16
add comment

On Mac the following works fine:

\documentclass{article}
\usepackage[applemac]{inputenc}

\begin{document}
Ç ç é É üäö
\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.