TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using flyspell mode, but unfortunatly I have to M-x flyspell-mode in each AUCTeX buffer.

Somehow (add-hook 'LaTeX-mode-hook 'flyspell-mode) doesn't work for me.

What is the correct flyspell-hook in AUCTeX?

share|improve this question
up vote 11 down vote accepted

Try (add-hook 'LaTeX-mode-hook '(flyspell-mode t))

This will force flyspell-mode to turn on, instead of toggling it.

share|improve this answer
thanks. That worked. removing the hook worked as well. The hook might have been sourced somehow otherwise (from text-mode?). – Dima Jul 30 '10 at 14:55
(add-hook 'LaTeX-mode-hook '(flyspell-mode t))

I would be surprised if the above worked.

The following works (using emacs 24):

(add-hook 'LaTeX-mode-hook #'turn-on-flyspell)
share|improve this answer

I would be surprised if

(add-hook 'LaTeX-mode-hook #'turn-on-flyspell)


(add-hook 'LaTeX-mode-hook '(flyspell-mode t))

worked at all in the current Emacs 24 and AUCTeX 11.87 that most GNU/Linux distributions include. in their package managers.

And assuming of course, that ispell is set in the init file. The following works in my end:

(add-hook 'latex-mode-hook
  (lambda ()
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.