Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Until now I had TeXLive 2011 installed and could successfully modify my memory settings using this solution with the TextWrangler approach to the question Memory settings with MacTeX - Which texmf.cnf to modify. After switching to MacTeX 2012 this doesn't work for me anymore. I already tried completely uninstalling all TeX-files and reinstalling only 2012, but that doesn't change anything.

Maybe this are some clues:

  1. When I try to modify /usr/local/texlive/2012/texmf.cnf in TextWrangler I get the message below, but it lets me change the file anyway after clicking Unlock.

  2. sudo fmtutil-sys --all runs just fine in the terminal, but I still get TeX capacity exceeded, sorry [main memory size=3000000], when LaTeXing my document, though the texmf.cnf-file is definitely changed.


EDIT:

Well, up to a value main_memory = 12000000 I am able to increase my memory by using this approach. Higher values don't seem to be possible. This solves my current problem. But as one is supposed to rather change the /usr/local/texlive/2012/texmf.cnf than /usr/local/texlive/2012/texmf/web2c/texmf.cnf I'm still happy about any clues or even an answer regarding my original question.

share|improve this question
2  
Is it possible that you at some point ran fmtutil instead of fmtutil-sys? If so, you need to delete ~/Library/texlive/2011/texmf-var. I just increased the memory on a new TL 2012 using the same procedure, and it worked as advertised, so I don't think anything has changed in this respect between TL 2011 and 2012. And you did save the changed .cnf file, right? (I'm sure you did, but it never hurts to ask.) –  Alan Munn Jul 28 '12 at 15:11
    
I'm pretty sure I never did that as I tried to follow your instructions to the mentioned question exactly. Nevertheless, I deleted all ~/Library/texlive/2011-folders and to be sure also the ~/Library/texlive/2012/texmf-var. The error still occurs. –  meep.meep Jul 28 '12 at 15:24
    
And yes, if I open /usr/local/texlive/2012/texmf.cnf in any editor, I can see my modifications. They definitely seem to be saved. –  meep.meep Jul 28 '12 at 15:26
    
When you compile a file that works, does the log file report the changed value of memory, or still the 300000? –  Alan Munn Jul 28 '12 at 16:00
    
It reports the original 3000000, not my changed number. I did another complete reinstall, this time using your emacs approach with terminal in case this is about TextWrangler. But the problem remains the same though the file displays my changes. –  meep.meep Jul 28 '12 at 17:06
show 2 more comments

closed as too localized by egreg, David Carlisle, Paulo Cereda, Heiko Oberdiek, Werner Jun 1 '13 at 21:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.