Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following the guidelines in the biblatex documentation p. 68, I am adding useauthor, useditor, and usetranslator to the options field of an entry in my .bib file:

@book{sweet1871,
    AUTHOR = "{Pope Gregory I}",
    TITLE = "King {A}lfred's {W}est-{S}axon version of {G}regory's {P}astoral {C}are",
    YEAR = "1871",

    EDITOR = "Henry Sweet",
    LANGUAGE = "Old English",
    LOCATION = "London",
    NUMBER = "45",
    OPTIONS = "useauthor = false, useeditor = true, usetranslator = false",
    ORIGLANGUAGE = "Latin",
    PAGETOTAL = "xlii + 509",
    PUBLISHER = "N. Tr{\char"00FC}bner",
    SERIES = "{E}arly {E}nglish {T}ext {S}ociety",
    SUBTITLE = "With an {E}nglish translation, the {L}atin text, and an introduction",
    TRANSLATOR = "{King Alfred}"
}

My .tex file looks like this:

\documentclass[a4paper, 12pt, onecolumn, oneside, notitlepage]{article}
\usepackage{fontspec,xunicode,xltxtra} % XeLaTeX
\defaultfontfeatures{Mapping = tex-text} % support TeX conventions like ``--''
\usepackage{polyglossia}
\setdefaultlanguage[variant = american]{english}
\setmainfont{Linux Libertine O}
\usepackage{csquotes} % for language-specific quotation marks
\usepackage[style = numeric, sorting = none, language = american, abbreviate = true, backend = biber]{biblatex}
\addbibresource{ReferencesBiblatex.bib} % my catalog of references

\begin{document}

\cite{sweet1871}

\printbibliography

\end{document}

The output, however, does not come out right:

enter image description here

Not only are my specifications in the options field ignored, but it's also not rendering the information about the original language correctly.

Here is my console output warnings:

Package biblatex Warning: Ignoring undefined option 'useauthor '
(biblatex)                at entry 'sweet1871'.

Package biblatex Warning: Ignoring undefined option 'useeditor '
(biblatex)                at entry 'sweet1871'.

Package biblatex Warning: Ignoring undefined option 'usetranslator '
(biblatex)                at entry 'sweet1871'.

Package biblatex Warning: Bibliography string 'fromLatin' undefined
(biblatex)                at entry 'sweet1871' on input line 158.

My question is - what I am doing wrong?

share|improve this question

closed as too localized by lockstep, tohecz, Torbjørn T., diabonas, Marco Daniel Sep 1 '12 at 17:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

5  
Looks as if biber doesn't like the spaces after the options. Write them as useauthor=false, –  Ulrike Fischer Jul 28 '12 at 17:36
3  
Try ORIGLANGUAGE = "latin", –  Håkon Malmedal Jul 28 '12 at 17:47
3  
This space issue will be fixed in biber 1.2. –  PLK Jul 28 '12 at 19:22
3  
Actually, it's fixed in biber 1.1 –  PLK Jul 30 '12 at 13:50
1  
I don't agree that this question is too localized. It identifies a more general problem, that biber doesn't accept spaces in the entries for useauthor, useeditor, and usetranslator. This could be considered a bug, and the authors of biber responded and decided to fix it. I'm voting for reopening the question. –  Sverre Apr 15 '13 at 10:18
show 5 more comments

1 Answer 1

Actually, it's fixed in biber 1.1

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.