Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

There is a problem with the sorting for Biber when using sortlocale=nb_NO.

\RequirePackage{filecontents}
\begin{filecontents}{test.bib}
  @misc{a,author = {A}} @misc{b,author = {B}} @misc{c,author = {C}}
  @misc{d,author = {D}} @misc{e,author = {E}} @misc{f,author = {F}}
  @misc{g,author = {G}} @misc{h,author = {H}} @misc{i,author = {I}}
  @misc{j,author = {J}} @misc{k,author = {K}} @misc{l,author = {L}}
  @misc{m,author = {M}} @misc{n,author = {N}} @misc{o,author = {O}}
  @misc{p,author = {P}} @misc{q,author = {Q}} @misc{r,author = {R}}
  @misc{s,author = {S}} @misc{t,author = {T}} @misc{u,author = {U}}
  @misc{v,author = {V}} @misc{w,author = {W}} @misc{x,author = {X}}
  @misc{y,author = {Y}} @misc{z,author = {Z}} @misc{ae,author = {Æ}}
  @misc{oe,author = {Ø}} @misc{aa,author = {Å}}
\end{filecontents}
\documentclass{article}
\usepackage[norsk]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[backend=biber,sortlocale=nb_NO]{biblatex}
\addbibresource{test.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

Compiling this file gives this result:

The letters Æ, Ø and Å should be last.

It seems this question looks too much like a bug report. I was kinda hoping for a workaround.

share|improve this question
2  
This looks like a bug report to me: have you logged it against Biber. (See meta.tex.stackexchange.com/q/2622 for how to handle such items.) –  Joseph Wright Jul 29 '12 at 18:54
    
What platform are you on? It works fine for me on OSX. –  PLK Jul 29 '12 at 19:18
    
@PLK I get the same with TeXlive 2012 on Ubuntu 12.04 –  Torbjørn T. Jul 29 '12 at 19:37
    
@TorbjørnT. Which Biber version? –  Joseph Wright Jul 29 '12 at 20:01
2  
This seems to be an issue only with the binary version. Running it as an unpacked perl program works fine on Linux. Looking into it. –  PLK Jul 30 '12 at 7:20
show 2 more comments

1 Answer

up vote 9 down vote accepted

This was indeed a bug in the packaging of the linux binary. I was packing slightly older DUCET 6.0 tailorings by mistake. Please get biber 1.1 from SF - it should be fixed in this build. You will also need biblatex 2.1 which is also on SF now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.