Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use a the jura package to write some home work in Law (to be honest, I'm just helping my girlfriend ...). Anyways, I the header of the document I have:

\documentclass[a4paper]{jura}
\usepackage[T1]{fontenc}
\usepackage{lipsum} % dummy paragraphs.

\usepackage[
    top=3cm, 
    bottom=3cm, 
    left=7cm, 
    right=.2cm, 
    width=500pt,
    marginparwidth=0pt]{geometry}

\begin{document}
\lipsum[1-5]
\frontmatter
\lipsum[1-10]
\end{document}

If I include the \frontmatter command, the definitions by geometry package are overridden (note that I need to use the jura document class).

How can I reverse this? Can I have an in-document (e.g. no it preamble) command to change the right margin?

share|improve this question
    
I see that the geometry package has such options, but I'm using Debian Squeeze, and I rather not start messing around with installing new latex packages ... –  Oz123 Dec 4 '10 at 11:03
    
I took the liberty of removing any unnecessary stuff from your example in the hope that it makes the question clearer and also added that you need to use the jura class. –  Caramdir Dec 4 '10 at 22:22
1  
(Manually installing TeX Live surprisingly easy and will give you all the updated packages and less bugs than the Debian/Ubuntu texlive packages.) –  Caramdir Dec 4 '10 at 22:27

2 Answers 2

alt text

\documentclass{jura}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc} %Silbentrennung
\usepackage{ngerman}%Deutsche Sonderzeichen und Silbentrennung (neue Rechtschreibung)

\usepackage{times}
\usepackage[%
                        a4paper,
                        twoside,
                        vmargin=30mm,
                        left=70mm,
                        right=2mm,
                        showframe=true%
                     ]{geometry}

\usepackage{lipsum}%dummy paragraphs.

\begin{document}
\frontmatter
\lipsum[1-10]
\end{document}
share|improve this answer
    
Note: I added twoside option. You can remove if you don't want two side document. –  xport Dec 4 '10 at 11:25
    
Is it mandatory to use jura document class? It is very old document class. :-) –  xport Dec 4 '10 at 11:34
    
@export, it is indeed a very old class, but i can't find a better replacement ... German law typesetting is pretty complicated. Also your solution does not work for me. Maybe it is bug in Debian ? Which OS you use ? which version of the Geometry packages do you use ? –  Oz123 Dec 4 '10 at 21:18
    
your code gives a different layout than the code in the question, or am I missing something? –  Caramdir Dec 4 '10 at 22:24
    
I think the original geometry option of @Oz123 is over populated. It means that the width=500pt will never be taken into account by geometry.sty. –  xport Dec 5 '10 at 2:05
up vote 0 down vote accepted

Ok, my lame solution so far is to use the package "chagnepage"

 \documentclass[a4paper,10pt]{jura}
\usepackage[utf8x]{inputenc}
% \usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc} %Silbentrennung
\usepackage{ngerman}%Deutsche Sonderzeichen und Silbentrennung (neue Rechtschreibung)

\usepackage{times}
% \usepackage{geometry}
\usepackage[top=3cm, bottom=3cm, left=7cm, right=.2cm,width = 500pt,marginparwidth=0pt]{geometry}
...
\usepackage[strict]{changepage}

\begin{document}
\frontmatter
\lipsum[1]
\mainmatter
\begin{adjustwidth}{}{-1.3cm}
\lipsum
...
end{adjustwidth}
\end{document}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.