Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Updated my tlmgr install (and all packages I have installed today) earlier today, and something changed in the font loaded by unicode-math, which I can't figure out of.

The preamble I've been using for making the beamer presentations is as below:

\RequirePackage{atbegshi}
\documentclass[smaller]{beamer}

\usefonttheme{professionalfonts}
\mode<presentation>{%
    \AtBeginSection{%
        }
\useoutertheme[nofootline]{wuerzburg}
\useinnertheme[outline,shadow]{chamfered}
\usecolortheme{shark}
\setbeamercovered{transparent}
}
\setbeamertemplate{navigation symbols}{}

\usepackage{fontspec,microtype,amsmath}
\usepackage{unicode-math}

\usepackage{siunitx}
\usepackage[retainorgcmds]{IEEEtrantools}

Before updateing, the font was as shown in [1]. After the update, as shown in [2]

[1] Before update

[2] After update

As I haven't changed anything at all in the preamble, I have to assume that one of the packages I use was updated (but since I didn't pay attention to the command line window I'm not sure of which).

I've tried to load unicode-math with the options math-style=TeX and math-style=ISO without any luck. Also tried to remove fontspec, microtype, and amsmath, but still the same.

Any input on how to get the font to be as it was before the update?

share|improve this question
1  
There is an issue at present due to a mismatch between unicode-math and it's support packages: see tex.stackexchange.com/search?tab=active&q=unicode-math. This could be the same thing. –  Joseph Wright Jul 30 '12 at 12:28
    
Not sure if I'm experienced enough to tell if its the same thing or not. But think I'll try to downgrade to a previous version of the package if I can find one anywhere. Thanks for the tip! –  militiaOfDeath Jul 30 '12 at 12:35
    
Ok, definitely the same issue. If you post it as an answer I can accept it and close this question. Again, thanks. –  militiaOfDeath Jul 31 '12 at 6:32
add comment

1 Answer

up vote 3 down vote accepted

There is an issue at present due to a mismatch between unicode-math and it's support packages: see Cambria Math becomes plain Cambria and 7-2012 l3kernel & l3packages updates | 'broken'?. The code has been updated, and I would expect this to make its way into TeX Live and MiKTeX over the next few days.

share|improve this answer
1  
Should now be fixed: try updating your TeX system. –  Joseph Wright Aug 1 '12 at 20:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.