Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to use Japanese Writing in my LateX document and for that I (think that) need to install the Mincho font, which is currently not fully available from mixTeX.

My Problem is that I need to be able to write some old japanese Characters which are not displayed when I use the following piece of code to write japanese:

\newcommand{\jap}[1]{\begin{CJK}{UTF8}{gbsn}#1\end{CJK}}

What I did till now:

  • I downloaded mincho-1-8-20080306.tar.gz from
    http://ctan.org/tex-archive/fonts/wadalab

  • I installed the files in my MikTeX installation

  • I changed the line of code from \newcommand{\jap}[1]{\begin{CJK}{UTF8}{gbsn}#1\end{CJK}} to \newcommand{\jap}[1]{\begin{CJK}{UTF8}{min}#1\end{CJK}}

I get the following error:

LaTeX Font Warning: Font shape `C70/mincho/m/n' undefined
(Font)              using `C70/song/m/n' instead on input line 146.

    ("E:\Program Files (x86)\MikTeX\tex\latex\cjk\UTF8\c70song.fd")
    ! Undefined control sequence.
    try@size@range ...extract@rangefontinfo font@info 
                                                      <-*>@nil <@nnil 

I'd appreciate any help on that matter. Especially I'd like to know where i can check if I installed the font correctly, or if there is any other way to get the characters showing that don't show with the "gbsn" font.

share|improve this question
2  
It looks as if files are missing (e.g. c70min.fd). Also you shouldn't use for your first tests a command with an argument like your \jab: This breaks if catcodes must be changed. But before wading more through the installation of fonts for CJK: Did you consider to use xelatex? –  Ulrike Fischer Jul 31 '12 at 7:23
1  
It seems that you did not properly install the font files. And it is really a pain to install CJK fonts for normal LaTeX users. I also suggest you to use XeTeX (via xeCJK) or LuaTeX (via luatex-ja). –  Leo Liu Jul 31 '12 at 9:16
    
Please add a minimal working example (MWE) that illustrates your problem. It helps for instance users to try out, whether it works with there MiKTeX installation. This leads me to a second advice: wadalab can be installed using MiKTeX’ own installation routines. Do you have language support for CJK activated? Take a look into the MiKTeX settings, not under “Languages”, but under “Packages” – “Language support”. –  Speravir Aug 4 '12 at 0:14
    
See also my answer in Specifying CJK fonts for pdftex and CJK.sty to get an example how to install a set of CJK TrueType fonts. –  Leo Liu Aug 7 '12 at 16:07
add comment

closed as too localized by Speravir, Joseph Wright Feb 2 '13 at 22:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.