Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

With a font in T1 encoding, using pdfTeX and the package microtype, I'd like to disable the ligatures for "ff" and "ffi", but keep the ligature for "fi". If I type in the preamble

\DisableLigatures[f]{encoding=T1}

microtype will disable all the ligatures above. How could I keep the ligature for "fi"? I have tried

\DisableLigatures[ff]{encoding=T1}

and

\DisableLigatures[f_f]{encoding=T1} 

but none works (as expected, though).

share|improve this question
    
I have a Type 1 face which works fine with the ligature "fi" but does not have the right glyphs for "ffi" or "ff". I could try with workarounds such as described in The TeXBook, but I'd rather proceed by disabling them explicitly, if possible. –  Marcos Jul 30 '12 at 23:57
    
@Kurt: Adobe Utopia Expert set Type 1 (.pfb). Everything works right except text figures (I get them, but then I have the wrong spacing for lining figures), and those ligatures. Actually, this comes from another question of mine that was post a couple of weeks ago. –  Marcos Jul 31 '12 at 0:06
    
That is strange. An expert set has ligatures for fi, ff, ffi, ... Can you show your problem with an MWE and the result? Can you add these information in your question? Then we can delete these comments. –  Kurt Jul 31 '12 at 0:12
    
@Kurt: I'll update the post with an MWE in some hours. What I can tell you now is that instead of the ligatures, I get a "Y" and a "V". Something may be wrong with the original font files, but I don't know how to fix it if that is the case. Whatever it may be, I'd also like to learn if what I'm asking in this post is feasible with microtype. –  Marcos Jul 31 '12 at 0:17
2  
You can disable only the "triple" ligatures ffl + ffi by using \char"1B in the declaration. But you can't differentiate between fl and fi. If you want to fine tune ligatures you will have to change the tfm files. Did you contacted the authors of fourier(x) regarding your other problem? –  Ulrike Fischer Jul 31 '12 at 7:09

1 Answer 1

You can disable only the "triple" ligatures ffl + ffi by using \char"1B in the declaration. But you can't differentiate between fl and fi. If you want to fine tune ligatures you will have to change the tfm files. Did you contact the authors of fourier(x) regarding your other problem?

share|improve this answer
    
Thanks for keeping this in mind. I have tried \DisableLigatures[\char"1B]{encoding=T1}, I have also tried with the value "1B, and even with char"1B, but none have worked. Did it work for you? Regarding the text figures issue, I am considering contacting the authors, but maybe it would be good to know if there is someone else who has tried and whether he or she found the same problem or not. –  Marcos Aug 8 '12 at 23:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.