Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a report on robot wars (as funny as it sounds).

One major section in my report is on EMP Cannons. Whenever I type EMP I get this:

\begin{minipage}[]{<+width+>}
    <++>
\end{minipage}<++>

I am using macvim with some latex attachement. Does anyone know how I can figure out where this is coming from and disable it?

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

This is a vim latex-suite macro, the official way to disable these is described here
http://vim-latex.sourceforge.net/documentation/latex-suite.html#latex-macros

However I had trouble getting those instructions to work in the past. Eventually I created a file ~/.vim/after/ftplugin/tex/afterls.vim and added the line call IMAP('EMP', 'EMP', 'tex') which just expands EMP to EMP.

This is a very silly way to do it so I am looking forward to seeing the correct answer.

share|improve this answer
add comment

This found it:

% pwd
/Users/jsummers/.vim
% grep -r EMP .
./ftplugin/latex-suite/wizardfuncs.vim:\."\n EFL   ".g:Tex_Leader2."fl   flushleft           EMP   ".g:Tex_Leader2."mp   minipage"
% 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.