Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I don't get any ligatures, like the fi ligature.

I'm using:

  • URW Century Schoolbook L (afai can determine anyway)

  • XeTeX, Version 3.1415926-2.2-0.9995.2 (TeX Live 2009/Debian)

  • Ubuntu 10.04

This is the relevant part, I think:

\usepackage{fontspec}
\usepackage{wasysym}
\setsansfont{FluxBold}
\setmonofont[Scale=0.85]{Bera Sans Mono}
\setmainfont{Century Schoolbook L}

If I drop fontspec and use fouriernc it works fine, I get ligatures, but I can't specify the other fonts. If I use both fouriernc and fontspec, this seems to clash so I get neither New Century Schoolbook, nor Century Schoolbook L.

I've also tries things like:

\setmainfont[Mapping=tex-text, Ligatures={Common, Rare, Historical}]{Century Schoolbook L}

To no avail. Setting Ligatures=TeX fails, it doens't know what TeX ligatures are. I've tried switching to luatex, but it seems to not be able to use the fontspec package.

I'm stuck.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I can't get ligatures to work with Century Schoolbook L or URW Bookman L. This might be missing ligatures in the font or maybe doesn't support Type 1 fonts that well.

The TeX Gyre Schola font is based on Century Schoolbook L and contains proper ligatures. If it is installed in the TeX directory structure, you have to use

\setmainfont[
    Ligatures=TeX,
    Extension=.otf,
    UprightFont= *-regular,
    BoldFont=*-bold,
    ItalicFont=*-italic,
    BoldItalicFont=*-bolditalic
]{texgyreschola}

to call it (or just copy the font to ~/.fonts).

However, this does not work with XeTeX/fontspec included in Ubuntu 10.10 (and so presumably also not with 10.04). If you want to use XeTeX and fontspec, I strongly recommend that you always use the newest versions. Installing TeX Live directly (i.e. not via the package manager) is not too hard (just download the installation script, run it and set the path) and will give you the newest versions of the TeX engines and packages.

share|improve this answer
    
Right, I tried mixing fontspec and non-fontspec packages and this didn't work. I'll try with the latest version. –  Lennart Regebro Dec 6 '10 at 18:23
    
That did indeed work with TexLive 2010. (Although my chosen mono font stopped working instead. Ah well.). –  Lennart Regebro Dec 6 '10 at 22:28
    
@Lennart: You should use DejaVu Sans Mono, which is an extended version of Bitstream Vera Sans Mono (the later can be installed through the ttf-bitstream-vera Ubuntu package). Bera is a Type 1 version of Bitstream Vera. See also the Wikipedia article. –  Caramdir Dec 6 '10 at 22:42
    
Yeah, that one works. I've been looking around for Mono fonts and haven't found one I think is perfect yet. I think it will be DejaVu Sans Mono or Inconsolata. –  Lennart Regebro Dec 7 '10 at 2:06
    
But with the above, the curly/smart quotes became ``Something'' in the output. Weird. I find it hard to believe that Tex Gyre Schola, being made for TeX doesn't support it's style of quotes... –  Lennart Regebro Dec 8 '10 at 12:53
show 1 more comment

Hey
I don't have the font Century Schoolbook L but using your code I get fine ligatures when using Minion Pro as main font.
Are you sure that the version of Century Schoolbook L supports ligatures?

My test file:

\documentclass{book}
\usepackage{fontspec}
\usepackage{wasysym}
%\setsansfont{FluxBold}
%\setmonofont[Scale=0.85]{Bera Sans Mono}
%\setmainfont{Century Schoolbook L}
\setmainfont[Ligatures={Common, Rare, Historical}]{Minion Pro}
\begin{document}
\chapter{Test}
Hello lets find some ligatures!
\end{document}

Sincerely,
Richard

share|improve this answer
    
This is probably the reason. I ended up trying to render it with every serif font I had, and found one that did support ligatures, so probably the Century Schoolbok L I have (from Bera, I believe) just doesn't have them. –  Lennart Regebro Dec 6 '10 at 18:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.