Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Lovely day. I am quite new to LaTeX but picking things up fast. One area which is confusing me greatly is getting my bibliography to work just how I like it.

I have settled on natbib with agsm style but there are still some issues.

  • The journal titles have apostrophes around them. (red in pic) I want to get rid of the apostrophies.

  • The volume number of a journal is set in bold. (blue in pic) I want it to just be plain (un-bolded).

This image added highlights these problems.

http://i.imgur.com/8lM01.png

Lastly, for the electronic copy, I would like it so the journal identifiers (DOI’s) are highlighted blue, so you can click on them and it takes you to the website of the journal article. (green in pic)

Help on any / all of the above would be greatly appreciated. I have searched online for about 8 hours and finally need to ask the lords of TeX.

Edit: This is my bibliography code so far I forgot to add:

\documentclass[11pt,a4paper]{report}
\usepackage[numbers]{natbib}
\renewcommand\harvardyearleft{\unskip, }
\renewcommand\harvardyearright[1]{.} 
\bibliographystyle{agsm}
\usepackage{hyperref}
\begin{document}
\cite{ref1}
\bibliography{bibFile}
\end{document}

Note - that renew command I found from this forum, it gets rid of brackets around 2008 which I didn't want. Thanks

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Find the file agsm.bst and make a copy, say, myagsm.bst. Next, open the new file in a text editor of your choice and search for the following line:

{ volume embolden field.or.null

(It's on l. 357 in my copy of the file.) Change this line to

{ volume field.or.null

i.e., tell BibTeX not to render the volume number in bold.

Third, look for the line

    { format.title quote "title" output.check }

in the file (it's on l. 698 in my copy). Change it to

    { format.title "title" output.check }

i.e., tell BibTeX not to place (single) quotes around the title. Finally, save the new file, update the TeX filename database if necesssary (say, by running texhash if you use TeXLive or MacTeX), and start using the new bibliography style by issuing the command

\bibliographystyle{myagsm}

from now on.

I should note that this is all extremely hack-ish. What you really ought to do is to run the utility program makebst, which will pose lots and lots of questions on just how you want to set up your custom .bst file. This utility will then create a brand-new bibliography style file that is based on the answers you provided. To run this utility, at a command prompt type latex makebst and follow the prompts.

An important additional advantage of using the makebst utility is that it will let you set up exactly what you think should happen with the contents of a field called doi. This is something you simply can't do by hacking the file agsm.bst -- short of a complete rewrite of the entire file, of course -- because the agsm bibliography style is quite old and doesn't even recognize the contents of a field named doi.

share|improve this answer
    
Dude, that's amazing. Thanks so much! Only one thing - when I rename it myagsm it says the citations are undefined. But it works as long as I keep the name agsm (I made a backup agsm). I ran that texthash from CMD (windows), so not sure what that problem is. I will try a makebst, but this so far is pretty much perfect. Thanks! –  Steve Hatcher Aug 6 '12 at 8:28
    
@SteveHatcher - delighted that the proposed changes work for you. About getting the new file (myagsm.bst) recognized by TeX and friends: be sure to save the new file in a directory that's searched by your TeX distribution; if nowhere else is available, just save it to the directory where agsm.bst is housed. Then run texhash (not texthash). If you use MikTeX, you'll need to click on "Update FNDB" in the main "Settings" window. –  Mico Aug 6 '12 at 11:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.