TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In a book, I set up indentation to be 1em for every paragraph, including the first paragraph in sections:

\setlength{\parindent}{1em}

However, TeX4HT doesn't honor this setting and sets the first paragraph to noindent.

How can I prevent TeX4HT from setting first paragraphs to noindent?

share|improve this question
    
Will it honour the indentfirst package? – jon Aug 5 '12 at 18:32
up vote 3 down vote accepted

There are many \noindents in tex4ht's configuration files, easiest way to solve this situation is to use custom CSS code to select p.noindent elements which are direct children of body (there are also p.noindents which are used in tables, theorems etc., where we probably don't want indentation)

Put this into custom config file or custom 4ht file:

\Css{body > p.noindent{
text-indent:1em;
}}
share|improve this answer
    
Perfect, thank you! – ℝaphink Aug 5 '12 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.