Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a book containing essays variously in English and French and wish hyphenization and other aesthetic issues to match whatever language is in use at the moment, but I want footnotes to follow a single style throughout. I've defined that style (hanging) using footmisc and have loaded babel with options [english,french].

My problem is that when babel is fed the option french, footnotes appear in French style, indented rather than hanging; if I omit the option french, the footnotes come out hanging, but there are periodic hyphenization errors. Below I show my code without option french (I've included geometry and \familydefault options in order to reproduce a particular error):

\documentclass[12pt]{book}
\usepackage[tmargin=1.25in, bmargin=1.25in, lmargin=1.25in, rmargin=1.25in]{geometry}
\geometry{letterpaper}

\usepackage[english]{babel}
\usepackage[hang]{footmisc}

\renewcommand{\familydefault}{qtm}

\begin{document}

Il est possible de tirer quelques conclusions de ces r\'esultats. Il para\^itrait que l'\'eglise du milieu du XIIe si\`ecle comportait vraisemblablement un chevet plat, construit sur l'emplacement du mur Gallo-Romain qui a \'et\'e arrach\'e sur une longueur correspondant \`a la largeur de l'\'eglise actuelle.\footnote{Apr\`es tamisage, les ossements et les deux planches ont \'et\'e remis en place sous l'escalier. Ces deux cercueils en ch\^ene \`a clous forg\'es semblaient assez r\'ecents.}

\end{document}

Output (observe the herniated right margin of the text and the footnote's hanging style): babel without french, text babel without french, footnote


Here is the code with french included in babel's input:

\documentclass[12pt]{book}
\usepackage[tmargin=1.25in, bmargin=1.25in, lmargin=1.25in, rmargin=1.25in]{geometry}
\geometry{letterpaper}

\usepackage[english,french]{babel}
\usepackage[hang]{footmisc}

\renewcommand{\familydefault}{qtm}

\begin{document}

Il est possible de tirer quelques conclusions de ces r\'esultats. Il para\^itrait que l'\'eglise du milieu du XIIe si\`ecle comportait vraisemblablement un chevet plat, construit sur l'emplacement du mur Gallo-Romain qui a \'et\'e arrach\'e sur une longueur correspondant \`a la largeur de l'\'eglise actuelle.\footnote{Apr\`es tamisage, les ossements et les deux planches ont \'et\'e remis en place sous l'escalier. Ces deux cercueils en ch\^ene \`a clous forg\'es semblaient assez r\'ecents.}

\end{document}

Output (observe the correctly justified right margin of the text and the footnote's indented style): babel with french, text babel with french, footnote


In addition, with babel set for English alone, I've tried setting the hyphenrules environment to french around the French essays, hoping to see only hyphenization follow French style and the footnotes be left alone, but no joy.

share|improve this question

2 Answers 2

up vote 7 down vote accepted

With a few changes your MWE is running. Change the line where you load babel (the change causes that you get the footnote style you want because english becommes the activ language) and change always the language with \selectlanguage{}. This is neccecary too if you load a language as class option. Here is the changed MWE:

\documentclass[12pt]{book}
\usepackage[tmargin=1.25in, bmargin=1.25in, lmargin=1.25in, rmargin=1.25in]{geometry}
\geometry{letterpaper}

\usepackage[hang]{footmisc}
\usepackage[french,english]{babel}

\renewcommand{\familydefault}{qtm}

\begin{document}

\selectlanguage{french}
Il est possible de tirer quelques conclusions de ces r\'esultats. Il para\^itrait que l'\'eglise du milieu du XIIe si\`ecle comportait vraisemblablement un chevet plat, construit sur l'emplacement du mur Gallo-Romain qui a \'et\'e arrach\'e sur une longueur correspondant \`a la largeur de l'\'eglise actuelle.\footnote{Apr\`es tamisage, les ossements et les deux planches ont \'et\'e remis en place sous l'escalier. Ces deux cercueils en ch\^ene \`a clous forg\'es semblaient assez r\'ecents.}.

\clearpage
\selectlanguage{english}

Text in English\footnote{This is a footnote. This is a footnote. This is a footnote. This is a footnote. This is a footnote. This is a footnote. This is a footnote. This is a footnote.}.
\end{document}

With texdoc babel you can read on page 106:

29.1 Basic interface
In a multilingual document, some typographic rules are language dependent, i.e. spaces before ‘double punctuation’ (: ; ! ?) in French, others concern the general layout (i.e. layout of lists, footnotes, indentation of first paragraphs of sections) and should apply to the whole document.

Starting with version 2.2, frenchb behaves differently according to babel’s main language defined as the last option25 at babel’s loading. When French is not babel’s main language, frenchb no longer alters the global layout of the document (even in parts where French is the current language): the layout of lists, footnotes, indentation of first paragraphs of sections are not customised by frenchb. When French is loaded as the last option of babel, frenchb makes the following changes to the global layout, both in French and in all other languages

share|improve this answer
    
Hm! Quite interesting. Many thanks for your help. –  brannerchinese Aug 7 '12 at 0:11
1  
It is also interesting that placing french before english as an option to babel changes the situation. –  brannerchinese Aug 7 '12 at 0:17
1  
It seems that babel activates the footnote style depending on the active language (the last one). So you can change afterwards the language with \selectlanguage for the right hyphenation ... –  Kurt Aug 7 '12 at 0:20
1  
I never cease to boggle at the hidden complexities of this remarkable tool, TeX. –  brannerchinese Aug 7 '12 at 0:28

Just add the following line after loading babel:

\frenchbsetup{FrenchFootnotes=false}

frenchb has lots of options to modify its behaviour.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.