Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I noticed that the paper size invoked by a4paper is not working right in my examples:

\documentclass[a4paper,11pt,oneside]{article}
\begin{document}
Test
\end{document}

I checked with Preview.app and it tells me the paper size is 21.59 cm × 27.94 cm. A4 should be 21.0 cm × 29.7 cm.

When I use \usepackage[a4paper]{geometry} I notice a different size of the paper (it gets narrower) and Preview.app says: 21.01 cm × 29.71 cm, which seems right.
I can reproduce this exact behavior with every class: article, book etc., scrartcl, scrreprt, etc., g-brief2 except memoir which gives me 21.01 cm x 29.71 cm

Is there something wrong or am I missing something?

share|improve this question
1  
Whait, the KOMA-classes give you the right or wrong size? –  Juri Robl Aug 9 '12 at 10:46
    
scrartcl etc. give me the wrong size –  niclas197 Aug 9 '12 at 10:48
1  
Try using the option pagesize when using the KOMA-Script classes. –  Juri Robl Aug 9 '12 at 10:50
    
Do you create a .dvi file from the .tex input and then run dvips etc to create the pdf file you then view in Preview? If so, check the settings in dvips -- it they may be the case that it's set to always create output with a page size of "US Letter" (8.5" x 11"). –  Mico Aug 9 '12 at 10:51
    
well I use pdfLaTeX but I tried every other typeset chain I know of (including XeLaTeX and LaTeX > dvips > ps2pdf) and it doesn't change anything –  niclas197 Aug 9 '12 at 10:54
show 1 more comment

5 Answers

up vote 22 down vote accepted

The a4paper option of the standard classes don't actually set the PDF page size, just the size which is used to set the text. That's why you should always use geometry if your class doesn't do that automatically. Most other classes do that by default as you see.

So no, there's nothing wrong and you aren't really missing anything.

If your page size in KOMA-Script is wrong, try using the pagesize option.

share|improve this answer
    
pagesize works for KOMA. Thanks! What's weird is that classes like g-brief2 which is for a DIN-Letter gives me the wrong size –  niclas197 Aug 9 '12 at 10:53
1  
Probably you mean \usepackage[pass]{geometry}, unless one wants to pass other parameters to it. –  egreg Aug 9 '12 at 12:28
add comment

With MacTeX it's possible to choose, at installation time, the default paper size for all engines. The choice can be reverted with TeX Live Utility: the "Configure" menu has the entry "Change Paper Size…".

Alternatively, the setting can be changed from the command line, by issuing

sudo tlmgr paper a4

or

sudo tlmgr paper letter

The paper format can even be set differently for each "engine", for example

sudo tlmgr pdftex paper a4

would set A4 paper only for pdftex based formats (so also pdflatex).

One can also state the paper size on a per-document basis: it's sufficient to say

\usepackage[pass,a4paper]{geometry}

to get output on A4 paper (independently of the engine used for compiling the document). Of course, the pass option must not be used if one wants to set other dimensions with geometry. The package will perform the appropriate steps for the typesetting engine used (latex+dvips, pdflatex, xelatex or lualatex).


Note that the tlmgr commands are valid for any TeX Live distribution on every system supporting it (the sudo prefix might be inappropriate on some systems).

share|improve this answer
add comment

From The Not So Short Introduction to LaTeX2ε:

Set the paper size with an optional documentclass argument such as a4paper or letterpaper. This works in pdfLaTeX too, but on top of this pdfTeX also needs to know the physical size of the paper to determine the physical size of the pages in the pdf file. If you use the hyperref package (see page 93), the papersize will be adjusted automatically. Otherwise you have to do this manually by putting the following lines into the preamble of the document:

\pdfpagewidth=\paperwidth

\pdfpageheight=\paperheight

share|improve this answer
add comment

running your example with pdflatex or xelatex gives:

voss@shania:~/Test> pdfinfo Namenlos-4.pdf
Creator:        TeX
Producer:       pdfTeX-1.40.12
CreationDate:   Thu Aug  9 13:06:20 2012
ModDate:        Thu Aug  9 13:06:20 2012
Tagged:         no
Pages:          1
Encrypted:      no
Page size:      595.276 x 841.89 pts (A4)
File size:      10796 bytes
Optimized:      no
PDF version:    1.5

that are correct values for A4. Also Acrobat shows with its properties 210 × 297

share|improve this answer
7  
If you're using MiKTeX, it may depend on your setting for "default paper format" if I remember correct. –  Juri Robl Aug 9 '12 at 11:14
add comment

Okay, I use MacTeX 2012 and using texconfig pdftex paper a4 in the Terminal works globally for pdfLaTeX.

For XeLaTeX xelatex -papersize=a4 index.tex works per document but a global option would be nice.

Am I the only one that thinks this bevavior is kind of strange?

share|improve this answer
4  
texconfig is an obsolete script; the right way for MacTeX (TeX Live) is sudo tlmgr paper a4 that will set the format for all engines. –  egreg Aug 9 '12 at 12:26
    
With sudo tlmgr paper a4 even XeLaTeX works. nice –  niclas197 Aug 9 '12 at 12:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.