TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to add a bibliography to my document. I create a test.tex:

\documentclass[twocolumn, a4paper]{ieicejsp}



I run the bibtex command and get a


Then I try to run the LaTeX and get an error:

'undefined control sequence \begin{thebibliography}{1}'

But the contents of text.bbl file are:


Saku Kukkonen and Jouni Lampinen.
\newblock Gde3: the third evolution step of generalized differential evolution.
\newblock In {\em IEEE Congress on Evolutionary Computation}, pages 443--450,


Please, what am i missing?


The exact error message was:

This is pTeXk, Version 3.141592-p3.1.11 (euc) (Web2C 7.5.4)
 %&-line parsing enabled.
pLaTeX2e <2006/11/10>+0 (based on LaTeX2e <2009/09/24> patch level 0)
Document Class: ieicejsp 
) (./test.aux) (./test.bbl
! Undefined control sequence.
<argument> \refname 
                    \@mkboth {\refname }{\refname }
l.1 \begin{thebibliography}{1}


As Joseph Wright suggested, adding


just before the


command solved the problem. Thank you! You have no idea how much you helped me.

share|improve this question
Please provide a link to the class file ieicejsp.cls you use. Not even the IEICE's Author's Guide provides this file... – Werner Aug 10 '12 at 5:30
Actually ieicejsp is a mystery to me. I got it from a friend. I just have to use it for a conference. It is dreadfuly long pastebin.com/D8tBUEK9 – Martin Drozdik Aug 10 '12 at 5:36
ieicejsp.cls does provide a thebibliography environment (see lines 705-722), so I don't know why there could be a problem; it is definitely "supported." – Werner Aug 10 '12 at 6:24
Thank you for your effort. I really appreciate that you dove into the monstrous document for me. Now the strangest thing happened. Even though there is an error, a file with the correct bibliography was generated! All of a sudden – Martin Drozdik Aug 10 '12 at 7:09
@MartinDrozdik Could you copy-paste the exact error you see? I get and error about \refname being undefined, which does seem to be the case looking through the class. That means its more-or-less broken, but doing \newcommand*{\refname}{Bibliography} should fix that. – Joseph Wright Aug 10 '12 at 7:48
up vote 3 down vote accepted

Maybe your ieicejsp doesn't support this? I tried your file with report and it worked (after doing multiple runs with pdflatex, so it could resolve the dependencies).

Note: Had to use another template, because I don't have ieicejsp installed.

share|improve this answer
Thank you! It may be the case. I will ask the person who gave it to me in a few days, accept the answer and post the solution – Martin Drozdik Aug 10 '12 at 5:38

The error indicates that \refname is being used by the class but is not defined. That is a bug in the class file: \refname is not defined by the LaTeX kernel, so any class using it should define it. It can be fixed by adding


after the \documentclass line in your document, but really I would be suspicious of a class with such an obvious error.

share|improve this answer
Shouldn't \usepackage[english]{babel} help too? – yo' Aug 12 '12 at 20:40
@tohecz It would, but I'd still say that the class is out-and-out defective. – Joseph Wright Aug 12 '12 at 20:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.