Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

I'm using Texmaker and I get this error "Log file not found" when I am running LatexPDF. Can you please help me to solve this problem.

share|improve this question

marked as duplicate by Werner, Kurt, diabonas, Thorsten, Martin Schröder Feb 27 '13 at 7:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  Marco Daniel Aug 11 '12 at 11:39
1  
@Rachelle What exactly is the workflow here? I assume you are creating a .tex file, then trying to run something, then getting the warning? –  Joseph Wright Aug 11 '12 at 12:35
    
Yes, exactly when i run any .tex file, then this warning pops up.. –  Rachelle Aug 11 '12 at 13:17

4 Answers 4

This error can occur if you have no TEX engine installed. Because TexMaker is only a editor and can therefor not compile tex code without a Tex distro installed previously.

If you are working on windows, make sure to install either TexLive or MikTex. http://www.tug.org/texlive/

For Mac there is MacTex. http://tug.org/mactex/

Hope this helps

share|improve this answer
    
It helps! Thank you very much.. –  Rachelle Aug 12 '12 at 1:17
3  
In this case please remember to mark this question as solved by clicking the checkmark next to the answer. –  Fry Aug 12 '12 at 8:33

I encountered the same problem in Linux OS, and I run the command line to compile the .tex file first to generate a .log file in the directory. Then it can be compiled by Texmaker without errors.

share|improve this answer

If somebody still encouters the problem, try to uncheck the "use a build subdirectory for output files" box. For me this in combination with Peiqins tip worked.

share|improve this answer

In my case, after trying many ways to solve the problem, I noticed that the name of the file I had to compile contained two spaces; I just renamed it and everything work fine.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.